Isn't it recognized by old Macbook?

Hello everyone

I participated in this forum from Japan.
My environment is a Mac mini 2012 catarina and the laser is an atomstak A25.
This is working fine.

I would like to use it with another MacBook Pro 2010, but it does not recognize the laser via USB.

Isn’t it recognized by old Macbook?

Hi JJ. Welcome. Akemasite omedetou gozaimasu. Happy new year.

I think technically the 2010 MacBook Pro should work. What version of MacOS is it running? I suspect it’s stuck on Mojave.

Does the USB port work fine with other devices? Or are you using a hub? If so, try removing the hub.

There may also be a driver issue. I’m not certain about the A25 but I believe other Atomstack lasers use CH340 usb interface chip. This is the same as Arduino devices. Lots of discussion about it here:
Mojave - CH34x USB drivers - installation - Using Arduino / Installation & Troubleshooting - Arduino Forum

Here’s one thing I found though at:
GitHub - adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver: CH340G CH34G CH34X Mac OS X driver

If you have ever installed a 3rd party driver before Mojave you might have a driver conflict.

Do not install if you have the current macOS Mojave 10.14 or later. macOS Mojave 10.14 (released in October 2018) includes a CH34x driver by Apple. If both Apple’s and the OEM driver are installed, they will create conflicting non-functional serial ports. Steps 1 to 3 below can be useful to remove the conflicting OEM drivers.

And here are the 3 steps they’re talking about:

1. Unplug any CH34* devices.
2. Unload the old drivers if running:
sudo kextunload /Library/Extensions/usbserial.kext
sudo kextunload /System/Library/Extensions/usb.kext
3. Remove the old driver by issuing one of the following commands (depending on your installation):
sudo rm -rf /System/Library/Extensions/usb.kext
sudo rm -rf /Library/Extensions/usbserial.kext


Thanks for the reply
I have a new installation of Mojave on my 2010 MacBook Pro.

CH340 is not installed.

It’s working fine now, but when I turn off the laser, I can’t find it.

Just in case, it seems to recognize that you turned on the laser before you started your computer.

Thank you

You mean to say that once you turn the laser off, that LightBurn won’t find it again until you restart your computer while the laser is on?

Can you make sure that the right port is selected in the Laser window? It will likely say something like “cu.usbserial-####” or something similar. If the laser is not on and connected this can sometimes default to something else.

If the right port is select try right-clicking the mouse on the “Devices” button. This will force a reconnect to the laser.


I’ve tried it many times now and Lightburn is doing well today.
I also wanted to use it on macmini2012, and I plan to use it on these two Macs, but sometimes neither of them was recognized by “Find My Laser”.
There was no problem with only mac mini.

Simultaneous operation of two units may be a problem.
I will keep watching for a while.

Thank you!

Sometimes LightBurn may not be able to find the Mac through “Find My Laser” but may still be able to connect. You can export the device configuration information by pushing the Devices button and then import into the new system. Or create the device manually.

berainlb PY

I am currently using it comfortably. thank you very much. I think we should build another topic … The Enable laser fire button does not work. I rebooted many times but it didn’t work.

What do you mean it doesn’t work? Do you get a “Fire” button appear in the Move window? That’s the only thing that changes when you enable that setting.

Fire button allows you to turn on the laser and see the light.

I should be able to see the laser with the frame button while holding down the shift key, but for some reason the laser isn’t shining and I can’t see it.

The “FIRE button” is not displayed on ma OS. As a result of my investigation, it was “holding down the shift key”. Am I wrong?

Follow these steps:

  1. enable fire button in Device Settings
  2. test fire button in Move window (it does exist in Move window after you enable it in Device Settings)
  3. adjust power level of fire button until the light is visible. Wear eye protection.
  4. Use Shift key when framing to be able to see light during framing operation.

Thank you
I didn’t understand how to use it.
Thanks to you I was able to use it properly.
This ensures alignment.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.