Issue with travel within fill shapes

Hi! I’m trying to engrave a simple shape (black fill in the attached image). Something is wrong with the output - notice how the outline is almost burned through and the inside shape (where the travel lines should be) is completely cut out. I purposefully exaggerated the overscan here. What am I doing wrong? Thanks!

PS: I tried turning on the ‘flood fill’ option and it’s a lot better, but the outline is still very pronounced.

Is this issue unique to this design or is this a new laser to you?

What material are you burning to? It’s not clear to me from the picture.

What do you observe during the actual engraving process? Do you see the laser light on for the entire area that should be engraved? Do you see the laser light on in the travel area where it shouldn’t be engraved?

Can you attach the .lbrn file here to review?

Hi! Thanks for your reply. I’m just testing with heavy paper at a very low power setting. Expecting the ‘black’ part to be engraved - that actually works fine - you can see the discoloration (lighter pink area), but also note the hole in a shape of a semicircle - that’s where the laser should be off for travel, but instead it goes on higher power and burns through the paper. Also… yes, this happens with other designs. The laser is not new - I’ve used it for cutting and it works fine for lines. I’m not sure if I’ve ever tried fills.

Test.lbrn2 (12.9 KB)

I don’t see anything particularly unusual in the design. But your symptoms are unusual.

The burned edges of the engraving even with overscan and the burning during the traversal imply some sort of power modulation issue.

Can you describe the type of laser that you have any potentially anything unusual about it? Your profile indicates a laseraxe but that’s not familiar to me.

If this is indeed a GRBL based unit can you run this in Console and return results:

1 Like

The controller is a standard cnc shield - one of those widely available on eBay. Powered by Arduino nano. GRBL is from here: GitHub - 1wise/
The laser is this: SW-LD59



Target buffer size found




$0=10 (stp pulse)

$1=255 (idl delay)

$2=0 (stp inv)

$3=1 (dir inv)

$4=0 (stp en inv)

$5=0 (lim inv)

$6=0 (prb inv)

$10=11 (rpt)



$13=0 (rpt inch)

$20=0 (sft lim)

$21=0 (hrd lim)

$22=0 (hm cyc)

$23=0 (hm dir inv)



$26=250 (hm delay)




$32=1 (laser)














I don’t see anything particularly interesting in the configuration. It’s not clear to me whether or not the laseraxe fork of GRBL is substantially different from standard. An initial glance reveals nothing obvious.

Can you confirm that your machine is configured as GRBL in LightBurn? Push the “Devices” button in Laser window, then click on the name of your laser. The device type will show at the bottom of that window.

Also, can you take a screenshot of Device Settings. It’s the screwdriver/wrench icon in toolbar.

Gotcha. Screenshots attached:

As you can see, I tried 2 things: the original Arduino nano with GRBL 1.1e, and a different Nano that I flashed with Laseraxe from the git repo above. Same results.

Again, I see nothing unusual here. At this point if I had to guess I’d say there’s some sort of hardware issue affecting power modulation. It’s also possibly a firmware issue.

You tried this with 2 different Nanos entirely? Was it on the same Shield or a different shield?

Can you try engraving a donut shape? So a circle in a circle set to fill. I’m curious of the result.

One possibility is that your laser module is ineffective at modulating power at low levels. Do you see the same behavior at higher power levels?

Heh, at this point, I’m pretty sure it’s a hardware issue. I switched the laser module from the PWM pin to the TTL pin and now it burns ONLY the travel lines. Basically inverse of the desired output…

To answer your questions:
Yes, 2 entirely different Nanos, but the same Shield.

I’m having a hard time imagining what you did here. Can you elaborate or take some pictures?

This would imply that the laser pwm is somehow getting pulled high when not being requested and pulled low when requested. CO2 lasers typically are setup to fire when pulled low so some boards support this but I haven’t seen that for typical Shields.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.