Issues I am having with 0.9.01

I just upgraded to 0.9.01.

Rotary settings for steps and roller size do not save (didnt work in 0.8.xx that i had previously)
The “Enable Rotary” button on the laser control panel on the right side has disappeared.

I have a AWC 708c lite.

Are you saying you do not see option as shown? If you look at the 9.00 release notes you will see that we have added the ability to display or hide this control from the main UI. Could that be the issue?

From the release notes: “- Added a setting to enable / disable the “Rotary Enable” control on the main window”

That was exactly my issue… Thank you very much!
one down one to go!

I just tried to change the rotary settings on my system and I am getting the same error. The steps per rotation and the Roller Diameter values do not save. I noticed at the bottom of the screen it says “Rotary setting update failed”. I am running LB on Linux with an AWC708C Lite controller.


I dont get any message in that area on my screen. I am running on Win 10. It seems to hold the settings I input cuz if it was using the settings that were there by default it would be seriously messed up lol. I guess its resets to default everytime you bring up the rotary settings screen.

EDIT - actually scratch that when I click the “Enable Rotary” button on my laser settings it pops up on the bottom with Rotary setting update failed as well. but not when I click ok after modifying the numbers

Just found out I don’t have to go to work today so I’m going to do some experimenting. The setting would have to be saved somewhere or else the enable rotary switch on the front panel wouldn’t work since it doesn’t open the setup wizard.

Rotary settings aren’t saved / restored yet for AWC.

Are they in effect once entered in the rotary setup wizard? Or is there no rotary support for AWC at all?

No support at all at this point, but it shouldn’t be long.

hmm… that is strange… I am having success with my rotary attached to my Y. I have not altered my um/pulse settings. I plug in the steps per rotation, roller size and diameter in LB and it seems to be having an effect when i change those settings.

Are you activating the rotary on the controller? Or only in LB?

Both. I enable it on my panel and have the current diameter and steps set there as well. As well is I do it in LB when I am creating the job… I wonder if I am just getting luck cuz the 2 mugs I am testing with are similar diameters.

Tried a mug with a considerably smaller diameter last night… It would appear that it holds the settings temporarily at least… If not I have no idea whats going on. I did run process monitor while attempting to update the rotary settings and it appears its trying to write somewhere that does not exist, but I assume that is known lol. Thought maybe by a fluke maybe was permissions related. with UAC and all in Win10

Took me a few tries to get the spacing/centering correct but it did work and was repeatable. Once the software updated so saving works it will do everything I personally need it to do for my business and we definitely worth the $110 cad!!

LB isn’t saving anything. You said you have the rotary enabled on the controller, that is why it works.

1 Like

OK so how are things not getting skewed when I switch to a different diameter mug then? I am not changing anything on the controller. The image i engraved uses the same 0.1mm scan gap. Sorry this is scrambling my brains a bit.

The linear translation doesn’t change with the diameter of the mug. If the roller rotates 20mm, the mug rotates 20mm.

right makes sense… but then why will the settings in LB care what the diameter/circumference of an object is?

It won’t matter for a roller rotary. It’s computing the circumference for you so you don’t have to, to know how tall the Y axis of the job needs to be for a perfect wrap.

Oh well. Saves me measuring it with my tape lol. Perfect!