Issues origin, frame and start using the controller

My Ruida controller won’t frame or start a file trough the controller itself, if I use Lightburn everything works correctly. All the other buttons (positioning, speed, power and pulse) are still working without a problem. This problem started yesterday; I haven’t changed any settings. The only thing I did different was start some files with the start button instead of sending it to the laser first. Did the same thing on my other lasercutter but there are no problems on that controller.

Things I tried:

The temp file is not loaded anymore, other files that are already in the laser won’t start nor frame.

I can send a new file to the laser trough the send to laser button but it shows same results as above.

Restarting the laser will reset the Y and X axis and the head will stay on the 0 mark, instead of returning to the last origin.

The controller I’m using is a RDV6442G
Connection over Ethernet, can’t pause the file on the controller if started from computer.

I have never heard of anything like this before.

How many files do you have in the controller itself? Ruida controllers get weird when they’re close to full, so if you don’t delete content from them often, I would start with that.

My next suspect would be the controller keypad buttons possibly being worn out, but you’d likely see very visible signs of wear before that happened.

The controller is fairly new, +/-6 months and you can hear the ‘beep’ when you click on the buttons. We got like 20 files loaded in, tried deleting a few, didn’t help. Today we did a full reset on the vendor settings and it resolved the origin, frame- and start issue.

The only problem we didn’t resolve is, when you reset the X and Y axis, it will still stay at the 0 mark instead of returning to the last place of origin.

There’s a controller setting called “Return position” (I think) that controls where the machine goes after a job completes (and presumably after power on).

I am unable to find a setting or something similar to “Return position”.

The issue that I am currently facing is that the laser no longer automatically returns to the point of origin after it finishes a job. Now instead it instantly stops where it finishes a job and just sit there until further instructions. It used to go back to its origin point when it finished a job but now it doesn’t.

The issue also occurs whenever the laser gets reset. Normally, it would go to the last origin point used. But now it stays at the X0/Y0 position.
The laser does seem to remember the last origin point since framing from any position still makes it start at the last assigned origin point, even after restarting the machine.