Issues with Laser location

Wondering if anyone has had this issue before. My location showed perfectly where it was on the build area until I used the rotary and switched back to the normal y axis. Now when I go to home the crosshairs are way down on the bottom left of my screen off the grid about the distance of the machine area. When I zero it goes from the bad spot to the home position but then my physical laser head is at what it believes is the zero point which is the top right corner. I believe I have all the settings correct including the origin point in settings in the lower left corner. Any help would be very much appreciated. I have completely uninstalled and reinstalled the software, deleted all the App Data and reinstalled, same issue persists.
Don’t really know if it’s a software or hardware issue

First thing to do is a backup of the configuration information before you modify it.

Since you eliminated Lightburn, it must have been something you changed in the configuration. Try going back through the setup for the rotary and double check that every change was returned to the original value. Does that make sense? :slight_smile:

Wouldn’t the original values all be reinstated after reinstalling the software? Right now I don’t even have the rotary set up.

Thanks for the reply

What exactly did you do when you used the rotary, just plug it in and it worked?
Somewhere you changed something. That’s what I’m looking for. :slight_smile:

Basically plug and play. I did change some settings but have since then installed and reinstalled

Did you change the machine settings or Lightburn configuration? If you have modified the machine settings reinstalling lightburn buys you nothing. It’s probably like I’m not following what you’re doing.

What settings EXACTLY did you change?

Yes, the settings for LightBurn. But, there are also settings on your control board itself. These are the settings Jack is mentioning. They are different things. :slight_smile:

I finally got what your getting at. The machine doesn’t actually have any settings. It has a emergency stop and reset switch, everything is completely controlled by Lightburn

While I understand what you are saying, this in not completely accurate. LightBurn is software.

You also have “Firmware” on the Ortur control board.

LightBurn can view and edit these firmware settings, but they are not LightBurn settings. They live outside LightBurn. If you use different software, you still need to have your firmware set in good order to drive your machine correctly.

The firmware used on your Ortur is known as Grbl. This link explains the details of what this is. Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

Something was changed in your firmware that may be causing the issues you are encountering.

Might be time to open a ticket with the nice folks at Ortur Support for additional assistance. :slight_smile:

Thanks for your help on this. I actually did have a ticket open with lightburn going already and the fix they sent me was to go to the console in Lightburn and type in $RST=* which totally reset the machine and now works as good as new. Just in case this could help someone else facing a similar problem.

Yes, this is one of the Grbl commands available to reset the control board. While accessible from LightBurn, these settings are for the laser control system and not the LightBurn settings.

$RST=$, $RST=#, and $RST=*- Restore Grbl settings and data to defaults

These commands are not listed in the main Grbl $ help message, but are available to allow users to restore parts of or all of Grbl’s EEPROM data. Note: Grbl will automatically reset after executing one of these commands to ensure the system is initialized correctly.

  • $RST=$ : Erases and restores the $ Grbl settings back to defaults, which is defined by the default settings file used when compiling Grbl. Often OEMs will build their Grbl firmwares with their machine-specific recommended settings. This provides users and OEMs a quick way to get back to square-one, if something went awry or if a user wants to start over.

  • $RST=# : Erases and zeros all G54-G59 work coordinate offsets and G28/30 positions stored in EEPROM. These are generally the values seen in the $# parameters printout. This provides an easy way to clear these without having to do it manually for each set with a G20 L2/20 or G28.1/30.1 command.

  • $RST=* : This clears and restores all of the EEPROM data used by Grbl. This includes $ settings, $# parameters, $N startup lines, and $I build info string. Note that this doesn’t wipe the entire EEPROM, only the data areas Grbl uses. To do a complete wipe, please use the Arduino IDE’s EEPROM clear example project.

NOTE: Some OEMs may restrict some or all of these commands to prevent certain data they use from being wiped.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.