Issues with OMTECH

We recently assembled and placed our newly purchased OMTECH 100w Red & Black, MF2028-100 - 100W CO2 LASER . I tried the test file and it cut only one line for 1 minute. I stopped it and checked things out. Upon further review the y axis doesn’t move. I can jog it along the X-axis just fine. When I push the Y-Axis arrows the digital readout shows movement, but there is none.

Also when I switch the driver plugs the x axis controller will move the y axis but the y axis controller will not move the x axis. With no power to the machine, the y-Axis moves freely without a bind or drag.

While these issues aren’t software is there a software, is there possible a setting that could cause this? I disabled the rotary just to make sure it wasn’t that.

Any suggestions?

1 Like

If I’m following you, the problem follows the Y axes controls from the controller.

I would think if the controller thinks it’s moving then it should be moving…

Sounds like the drivers/motors are good…

If the wires are in the connector OK then it points to the controller and I don’t know how you could ‘fool’ it via a ‘setting’ within the device.

I’d ‘tug’ on the wires and ensure they are not only connected, but not just held in by the insulation. Also that the connector is seated like the surrounding ones… I suspect you’ve done some of this…

There are only a few wires to the driver you could probably compare them with a voltmeter to ensure you are getting the signals… scope would be nice, but I think a voltmeter would at least give you an idea…

Make sense?

If all this fails, I’d contact OMTech, that’s why they get the big bucks…

Good luck



Thanks for the Reply Jack.
Since the drivers and motors work when swapped it leads me to believe the up/down arrow is not submitting information to the drive/motor.
I did check that the Yaxis is getting power (5V) and both Axis. I may try to disconnect all the wires and reseat each one individually.

I have contacted OMTECH multiple times over the past week. Not much help this far other than offering troubleshooting I was already doing. I have requested a new motherboard.

Does the machine home properly when you turn it on? Both axis move?

1 Like

The machine does not move properly at start up. The X-axis is the only one that moves. It “homes” the X-axis and just zeros out the Y axis. Y axis doesn’t move but axis shows 0

You might be able to swap the connectors at the controller to see if it moves the Y axis

I did that. The left and right buttons then controlled the Y axis movement and it would move. But the up-and-down arrows would not control the X axis. This is what I would have thought If there was a controller issue. Basically I have proved out the drives and the motors.

Ok I thought you swapped them somewhere else.

1 Like

If it cannot home, it won’t give you a zero value for the X axes.

If that axes does not have homing enabled it will only home on the ‘enabled’ axes…

Screenshot from 2022-05-03 17-44-44

I disabled homing on the X axes and it only homes on Y, but I still can move the X axes…

I’m running out of ideas… :frowning:


1 Like

Well, I did that too.
I’ve tried a lot.
I am running out of ideas.

I will try this setting in Lightburn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.