$J jogging and continuous jog mode options not available


I’m using lightburn 0.9.20 on windows 10 64bit, and trying to setup continuous jog mode. everything i have found is telling me to enable $J jogging and continuous jog however these options are not available. no buttons to enable this feature.

No $J jogging button to enable

What am i doing wrong…


You are probably using the Grbl M3 profile which doesn’t support $J
If you are running Grbl 1.1f or newer you should be able to switch to the regular grbl profile and then enable $J

Hi, thanks for the quick reply i am using grbl 1.1h custom x,y homing, with $32 laser mode enabled. i dont quite understand what you mean by Profile.

If i use LaserGrbl i can jog no problem with the current GRBL firmware 1.1h custom x,y homing


When creating your device profile, choose GRBL, not GRBL-M3

Thanks alot that worked, now when i enable continuous jog under the move tab the arow keys to jog the z axis are greyed out and only work when continuous jog is turned off, just need to find a way to jog z axis with this enabled if its possible.

Also is it possible to jog using keybord keypad ?



I have figured out how to use keypad jogging but this is not continuous. can someone please clear up a few questions.

  1. when continuous jogging is enabled the z axis arrows are greyed out.
  2. when continuous jogging is enabled i cannot use keybord key pad.

is this the way it is or am i overlooking something ?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.