Jagged edges on chuck rotary burn

I am getting jagged edges when using my rotary. Suggestions on how to fix?

Machine is self built, Latest GRBL on an arduino.

my settings are:


Your $102 = 80 steps per mm
My $102 is 250 steps per mm.

Open the Cuts / Layers window. Double-Click on the layer you’re working on. A window will pop up with the Cut settings editor. You should see a value for “Line interval”, kindly post that number. I think the problem is the distance between Line interval and Steps per mm.

Line interval is 0.100 mm

the 80 steps per mm. is derived from my stepper motors 200 steps per rev, 16 microsteps and gt2 pulley with 20 teeth.

The problem with a gt2 pulley is that they can be 2mm, 3mm and 5mm pitch. Mine on my Bachin Maker are 3mm pitch.
I assumed it was 2mm until i measured it with a caliper.

gt2 = 3 mm pitch = 3mm/ tooth

(200 steps / rev) / (20 teeth/rev) = 10 steps per tooth

(10 steps / tooth) / (3mm/tooth) = 3.3333 steps per mm

(3.3333 steps/mm) * 16 microsteps/step = 53.333 microsteps/mm

This would have come out at 80 microsteps per mm if the belt pitch was 2 instead of 3.

In the move window, request a 40mm z-axis move.
If it moves a measurable 40mm along the circumference then the current assumptions about motion and geometry are correct and the line interval should change. I’d use a sewing tape measure or a length of wire to confirm.

I tried burning a 40 x 10 square in line mode, to easily measure. This presented an exact 40mm travel.

1 Like

I don’t have your setup but I run my line interval at 0.04

1 Like

Around the perimeter of the cup? perfect.
The geometry is correct. I would attempt an adjustment of line interval.


This just did not make any sense to me, as all settings were correct in software, I figured it had to be at hardware issue. Tried a new arduino, different stepper motors and drivers, all with same result. I then replaced the cnc shield for the arduino, and there it was. All is working fine now.

Thank you all for taking the time to help me.

1 Like

That’s amazing! congrats.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.