JCZ BJJCZ controller not holding in device manager

Has anyone ran into an issue where when connected to the laptop directly, you get this error…??
image (2)

Might check out the drivers… this seems to happen… there is no other way to connect to these controllers other than usb… as far as I know.

Did Windows do an update of any kind…?

If you ran EZCad2 you cannot use the same drivers as Lightburn…


I have been through his course numerous times, I have had the SFX dial in, and even their support team dial in. Is it possible the control board is corrupt?

Anything is possible, but I’d be surprised if it were other than some kind of connection with the usb system…

They do talk to each other at the os level when you plug it in. I would have to assume it couldn’t find the correct driver…

I have no other suggestions… I’ll keep it on my mind…

Good luck


This is message I keep getting in my device manager.

image (1)

I will say also, I believe I have a USBLMCV4, and not the V2?

Have you ever run with Lightburn?

I just looked at my usb on the Ubuntu and it says…



I have always used Lightburn. I have no issues running my C02 with Lightburn. This issue with the driver has just started in the last few weeks. I have been running my fiber since I bought it in Aug 2022, running Lightburn the whole time.

That makes it a bit tough… do you have access to any warranty from the vendor? They have ways of testing the controller, I understand…

Since you’ve been though the driver issue, I’m out of ideas… sorry…

Good luck


I have been in touch with the manufacturer, and they have looked at my computer through team viewer, and they couldn’t get it to work right. I keep asking them if it could be a hardware issue, and I never get a straight answer.

If you previously had this working with LightBurn, that strongly suggests this is a physical connection issue rather than a driver issue.

A good first step, if you have not already done so, is to try a new, high quality, shielded USB cable.

​There’s also a run of USB cable going from the outside of your laser’s case to the control board within. Sometimes that port or run of cable can be faulty, or routed too close to a power supply, leading to interference. Try opening the case and connecting directly to the port on the ​control board, bypassing that run of cable.

Hey Tyler,

That was also a step they had me do, and had same result. I did run a direct line from the control board to my laptop. Will you send me a link to a cable you would recommend? Maybe the cable I tried wasn’t up to par?

Sorry, I don’t have any particular cable to recommend - just searching Amazon for ‘shielded cable’ should turn up lots of hits. It doesn’t need to be particular special, just something known to be new and of good quality. If you’ve tried more than one cable already, it couldn’t hurt to try another, but it’s also less likely that that is the solution.

Do you have another computer handy you could try connecting with? If you see the same behavior with multiple computers and multiple USB cables, my guess would be that the board is faulty as you suspected.

I can try my older computer and see how it reacts. The issue I am having now is the manufacturer (SFX) is not communicating very well anymore, and my requests for new hardware assessments are never answered. Machine came with a 2 year warranty. I purchased it in Aug 2022.

Sorry to hear that - unfortunately I think this issue will need their attention if you see the same issue on a different computer. Hopefully they will get back to you sooner rather than later.

Thank you for your help.

Several years ago I had a very severe problem with the direct to USB connection between my Red&Black and a brand new Dell e7640 laptop. I could not get any help from Dell and I didn’t get any help from the Red&Black mfg. I returned the laptop thinking it was the problem. The second laptop did not work either. I then read an engineering synopsis that said there could be problems with voltages between the different laptop ports. I ended up ordering a USB isolator on eBay. I believe I paid about $8 at the time. The isolator makes it so the voltage problems between the two ports are not allowed to prevent communication. All my problems were solved. I am still using the same $8 isolator. The one I bought looks a lot like a USB thumb drive. A quick check on eBay shows they are running for about $12 now. Hope this helps, if not, at least it is not a big expense.

Minor surgery on the laser revealed it was a bad usb connection from the control board through all ports, and to the computer. After a direct line was taken from the control board to my laptop, it apparently corrected the issue. Fingers crossed.

I didn’t realize I had a similar issue, but it was just where the usb plugged into the fiber… it was lose inside the machine…

Sorry I didn’t think of this as a check point…

Glad you’re up again…

Take care