Job is choosing a bad start point for cuts

I’m having an issue with Lightburn picking a bad starting point on a shape. I’m cutting acrylic rulers, and if the start point is along a line, I’ll often get a slight bump or deformation at the point where the laser starts and stops the cut. To correct this, using Trotec’s Job Control, we have always selected a starting point for our lines in Illustrator that is at a corner. Here is the problem that I’m seeing:

As you can see, I have the start point in Illustrator set to the corner of my shape. Lightburn is choosing to start in the middle of the line. Here are the things I have tried:

  1. Disabling all cut optimization
  2. Enable/Disabling Choose best starting point and Choose corners, if possible
  3. Turning all of the optimization settings on/off one at a time to see if anything affects how LB chooses the starting point

Any help here would be much appreciated. I have orders to cut and am falling behind while I try to figure this out.


I just found the Set start point tool, and even after explicitly selecting the upper right corner of my shape as the start point, and seeing the little blue arrow indicate that the corner is the start point, Lightburn is still ignore the setting altogether.

I’ve tried both with and without cut optimization turned on after setting the start point.

I would have to look at your file to see if I can help.

I have just did another series of testing and I get the expected results. In LightBurn, I drew a 50x50mm square, then used ‘Array’ to duplicate 4 copies to the right (totaling 5 squares), selected all shapes and selected ‘Edit’=>‘Convert to Path’. With all 5 shapes selected, I then changed to the ‘Set shape start point’ tool and changed both the start point and direction of the cut path so each would be different. I set 'Cut Optimization Settings as shown in image. Previewed to check order and all works as it should.


Do you have a kerf value set? This rounds corners (so they don’t get caught by the “choose corners” code) and because it reconstructs the shape from scratch, it nukes the user chosen start point as well. I have a task on my list to identify the closest point on the new shape to the original start point, but it’s not there yet.

That makes sense. Please let me know when you have a fix out and I’d love to test it.