Job stops with Creality Falcon Pro 10W and LB 1.6.0.0

Good afternoon (o;

Just got my Creality Falcon Pro 10W today and hooked it up to my Debian laptop running LB 1.6.0.0.

What is odd, that a job suddenly stops after few minutes without any errors in the console…also the laser window doesn’t show the progress anymore and tells me, that the laser is ready.

When saving the GCode to a TF card and plug it into my Falcon Pro, the job runs fine through.

The picture shows on top the two stopped jobs, at the bottom the job run directly on the Falcon Pro with TF card inserted.

Also to note that when running a job over USB, the letter “m” shows a shift.

Another job I tried on stainless steel over USB: Left with 100% power and right with 80% power.

Anyone having the same issues?

Tried yesterday 1.6.03…but still the same…

Sending a job from within LB to the Falcon Pro 10W just doesn’t work reliable…

When some horizontal shifts occurs I see the GRBL error code 24…some mention here that the USB cabling is faulty…but don’t see how that could be related at all…

Anyway…had to send the machine back today as the left side from the X gantry with the wheels is totally bent and causes the belt to rub against the Y profile.

Good morning

Tried now an a MacBook Air M2 with LB 1.6.03, though had to add a small USB hub as USB-C to USB-C doesn’t work as macOS won’t recognize the serial port then.

The same errors in the console appear and the job stops around 40% through.

So far Creality is totally clueless as they suggested me minutes ago to check the mechanics :wink:

If there is no solution soon from Creality I most probably have to open that control box, do some reverse engineering and compile my own grblHAL firmware for the ESP32-S3 chip.

Found it (o;

The ESP32-S3 firmware just doesn’t like buffered transfer mode…

Needs to be synchronous…baud rate doesn’t matter…

synch mode will REALLY slow down your laser.

Something else is going on with your setup.

Are you using the latest firmware?

IF you run in buffered mode but max power 1% does it stop the same?

The console tells me that I have a more recent firmware that Creality lists for downloading. Theirs is from 2022 where mine has one from September 21st 2023.

Their supplied lbdev file shows transfer mode 0, so according to them buffered mode should work. And it is my second Falcon Pro engraver with the exact same errors (First one had a bented X-gantry).

But how would laser power affect the communication?

What puzzles me is that the device comes with a 72W power supply. Normally diode lasers with 10W optical power draw them self as much or even more.

Just tested with 1% power and buffered mode…

Stops at the same spot and throws the same errors in the console:

[VER:1.1f.20220810:]
[OPT:VHL,127,65536]
Target buffer size found
[software versions: CV30-Pro-MASTER-Release V1.0.0 20230921-0947]
ok
Starting stream
Layer C02
error:2
Numeric value format is not valid or missing an expected value.
On or near line 0:
Job halted
Stream completed in 6:47

Then loads of lines with “ok”, and then:

error:24
Two G-code commands that both require the use of the XYZ axis words were detected in the block.

followed again by loads of “ok” messages.

CR_Falcon_Pro_10W_Lightburn_Console.txt (1.3 KB)

Any chance you are using GBRL LPC?
Check here:
GRBL Types

Ah no….

The lbdev file from Creality sets it to GRBL.

Sadly there isn‘t any ESP32-S3 support for FluidNC. Otherwise I would have wiped it (o;