Jobs keep 'HALTING' almost immediately after starting job

At the beginning, LB would crash unexpectedly but LB has been running fine for about 6 weeks now. Suddlenly on Sunday, things went haywire. It started “halting” the jobs on its own. The program would say it was " busy" but nothing was happening. All the control buttons (pause, stop, home, etc) were non-responsive. I would have to quit LB. I would reboot and the same thing would happen but the “halting” would happen quicker to the point that within 5 seconds of the job starting the job would be frozen. Please note. I had not changed any settings at all. I don’t know why this problem suddenly started happening.

What have I done to try to remedy?
I have checked all connections.
Ensured the most recent LB version is installed.
Ensured my Mac operating systems are up to date.
Ensured my X-Tool operating software is up to date.
I have tried using a brand new Mac to check to see if my ports on my older Mac were working. (NOPE. Same problem on the new Mac).
I have also tried to see if my MACs will run the X-Tool XCS software to operate the X-Tool. It works.

Therefore, in my mind, this is a software compatibility problem between Mac, LB and Tool. I just don’t know how to resolve this. I want to keep using LB as it is the better software. But, at this point, it will NOT work.

I have an email into LB proper but they sent an automated response to try here first…

Please. Somebody please give me a hand. I have a show on Saturday which I had planned on taking special orders for personalized items. At this point, I don’t feel like I can offer that.

I am running LB with a MacBook Pro to operate a X-Tool D1 Pro 20 watt. My Mac has Monterey 12.6 on it but I am uploading Ventura now. I brought out my new Laptop with Ventura on it and it had the same problem. For this reason, I know that my ports on my laptop for the XTool are working. LB is version 1.2.04. I tried using my laptops to run the stool with their XCS software and it works. Thus, it seems this is a compatibility /software issue with LB and Mac. Looking forward to hearing from you all…

Happy Holidays to you all…

Ruth

Was there a message in the Console window in LightBurn when the job halted?

Did you change or move anything about your set up prior to the sudden change on Sunday? xTool may have a tilt or accelerator feature that might complain when on a more compliant piece of furniture.

xTool suggests the USB ports might go into power conservation mode.
as a fallback after the firmware is updated.

What is the Firmware version displayed when the xTool D1 Pro connects to LightBurn?

I did not change or move anything about my set up. I have been making multiples of the same file.

ok
[MSG:Pgm End]
Starting stream
Layer Labels
M8 N1Job halted
Stream completed in 2:41
protect_flash_ret:0x105, flash id:c84017