JTech Shapeoko cinnection

I connected my JTech 7w laser to my Shapeoko but the console says waiting for connection. It has a com4 port available, the Shapeoko is plugged in and powered on. I have also made sure to select the GRBL1. So I am not sure what the problem is. Anyone?!

Try a different com port.

Which Shapeoko do you have? Does it require the CH340 driver?

I’ll try
a different port on my laptop. Is that what you mean?

I have the shapeoko xxl. I don’t think I need a driver. I had it hooked up and it ran fine a few months ago. I had since disconnected and when I dusted it off and sedt it all up today, that was the message I got.

The ‘waiting for connection’ message can be misleading. USB seldom has wait times of more than 3-4 seconds. I believe that your computer is not detecting the engraver on the Com Port that is selected/defaulted.

Plug in all your stuff, turn it all on, start LightBurn.
Open the Laser window in LightBurn and look at the bottom middle of the window and click the button in the middle and see if you have any options there.

If you do have some options there, select a different option (wait 3-4 seconds), and then open the Console window and see if the computer can see the engraver.

If it won’t connect by doing this, installing the driver is probably the next step.

awesome, thanks I will try that now.

which carbide motion am I downloading for the JTech to work? V3 or 5

In what way does the Jtech not currently work? It sounds like you have several things going on here.

The Carbide Motion software has a driver that might let you communicate with the controller - if you’ve tried other USB ports and if the computer talks to the GRBL controller then that part is done.

Did you get past “Waiting for Connection.”?
How many other com ports were offered in the Laser window?
Did any words appear in the Console window?

I’m going to check it now. I just downloaded carbide motion (updated the version I had, basically) and now I am going to check it out now

I got it working!!! Thank you soooo much!!! :slight_smile:

1 Like

new problem I have is I cannot seem to get it to laser in the right spot. It keeps shooting to the far right back corner of my router table area. I’ve tried all options, abs… coord, user orig and current position. None of them seem to go where I’d like to laser

Great! start a new thread and we’ll let this one rest. Was it the driver in the Carbide Motion 5 that got you going?

yes, I believe it was.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.