Just tried to update to v0.9.24

I just got the notice there was an update available to v0.9.24 and tried to update. I got a message that the file COM Surrogate was open and needed to be closed. The installer will not close that file. I’m on Win 10 64. I did a little research and tried to manually shut it down without any luck.

Anyone have any ideas? Thanks.

Picked this out of another post from Oz:

COM Surrogate is the Windows process that runs the thumbnail preview tool, so that’s what is holding on to the files for some reason. I’ve seen a couple others with this issue, but I’ve never had the problem myself, and haven’t been able to figure out what causes it. Everything I’ve found online so far suggests this is an issue with Windows itself - I’m still reading to see if I can track down why it’s happening.

Try changing the View in the windows file explorer to “Details” instead of thumbnails, and see if that helps. If it doesn’t, restarting your PC should clear those locks.

You can also do this:

  1. Press Ctrl + Shift + Esc to start Task Manager
  2. When Task Manager starts, find the COM Surrogate process and right-click it. Choose End task from the menu.

Try that and let us know how you get on. :slight_smile:

I tried shutting COM Surrogate off every way I could find online before I posted in here. I set my explorer view to details and still does the same. I did install the update on my second computer (that already had LightBurn installed) and it went right through.

The second computer is Win 10 also and will be just a graphics computer for PS, AI and LightBurn.

I did try by selecting don’t shut COM Surrogate down in the installer message but it wouldn’t install that way either.

I’ll keep digging and see what I can find.

Had the same issue. I ignored the message and continued, the install worked fine.

Thanks Stuart. I had just turned on my computer and found your message. I decided to try one more time. I did try ignoring the message yesterday but it didn’t work.

I tried again this morning and didn’t even get the message. It installed without any problems. I may be running something on my computer that requires COM Surrogate and keeps it running.

If I have any issues with the next update I will completely shut my computer down and the install the update.

I’m thinking it could be related to Photoshop or Fast Picture Viewer Codec Pack but I’ve been using those for a long time and all previous installs went smooth.

Thanks for all the replies and help. This can be closed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.