Just updated new lightburn, now not able to send to laser

I have simmilar issues, Just got notifaction of new version, and now poof, i cannot send anything to the laser, I can delete files from laser but cannt send to laser, I have uninstalled and reinstalled, no luck, installed old version, still no upload to laser. I can however run the laser and cut IF i run/cut direct from PC, but i never do this, i always send to controller then I do my cutting, in case the PC has issue. I have customer orders due tomorrow. Windows 10 Ethernet connection Rudia Controller. Everything has worked perfect until this update

and then you say…

Which is it?

Please walk us through your steps, what you do, what happens or not in as clear of a way as you can. Please remember, we can not see or observe what you see, so the details matter. Provide as much in as clear a way as you can. This really helps you get the fastest and most definitive responses.

I have been Doing the same thing as I have since the first version and it has always worked.

I have narrowed it down however, If i draw shapes inside the program it will upload to the laser and work as normal.
IF i import a dxf file , it will not upload to the laser controller memory, HOWEVER it will cut from the PC as in if i hit start the laser works as expected.

Since version 0 I have always done the same thing, dragged my dxf into the window, set my colors and speeds/power etc, hit SEND (to controller memory) and bingo it works. I just updated to the latest version an hour ago and not it will not send to controller. This is new issue, as i have been with lightburn since its first public release. I have also tested this in RDworks and it uploads to controller memory no issues.

If even tried importing files that i cut yesterday and hit send to send to laser so i can go to laser and hit start and they will not upload, same error all the time, "File transfer failed There was as problem sending data to the laser. the machine may be paused " but anything i draw in lightburn works and sends fine.

Is the controller memory file list full by chance? There is a limit. You may need to set the controller to purge first in if you can. Otherwise, you may need to clear some files from the controller to have room to place more in the controllers list living ON the controller. When you hit ‘Start’, LightBurn is streaming the file directly and no file is sent to live on the controller for later use from the controller HMI without the need for software running on a PC.

1 Like

I have purged the controller. I can send files to the controller via rdworks with no issues, i can then see them from lightburn and “delete all files” so i know the controller is empty.
This was all working yesterday and today up until i installed this update. I have rebooted the PC and controller. I 100% of the time send the files to the Controller so that i do not need the PC. From what i know SEND , send to the controller memory and Start live streams to the controller, I always Send just in case computer has a bad time or power flash etc.

IF i draw some shapes in side light burn it will Send to memory no issues, its when i import anything, even stuff i cut eariler today, it will fail to send to controller memory, but it will live stream and cut it. Are there any hidden DLL’s that i can purge that deal with importing dxf’s ai’s ?

Also If i have a imported dxf file and some shapes drawn with lightburn, the lighburn shapes will send to the controller memory, but the imported dxf shapes will not, this points to a software bug ? as this shows the controller memory is not full and will accept new files.

Have not seen this issue reported before so thank you for that.

the very odd thing that this worked this morning and has worked perfect in all other version, but it just randomly broke with this upgrade and installing previous version does not fix this, are there hidden dll’s or associated dll that are not purged with a uninstall that i can removed, I did remove files in C:\Users\jerom\AppData\Local\LightBurn but this did not fix the issue.

Another thing i am seeing is that, even though the file transfer fails, it does create the file name on the controller, but has no data. again this is only with imported files, dxf ai etc. anything drawn inside LB works no issues

So, you are saying this issue is the same irrespective of the imported file format, is that correct?

Which version were you running before?

If everything worked perfect until this update, and then you reverted back to the version that worked before, and that isn’t working either, then there’s a good chance that the update isn’t the problem, and the timing is a coincidence (it does happen).

LightBurn doesn’t care if a shape was drawn in LightBurn or imported - there’s really no difference between those. When you import something, is it the same color as the thing you are drawing manually? (on the same layer, using the same settings?)

Please import a file that’s not working, and attach the LBRN file here (or email it to support@lightburnsoftware) so we can have a look.

i was using 0.9.16 and have been upgrading every release. Like i say this was working earlier, but then well windows updates happen too and love to break things.

Washers_X400.lbrn (107.9 KB)

I have cut this file a dozen times over the last year and today it wont work, although it will stream, but i rather not do that as the material it is cut out of is rather expensive

test.lbrn (94.9 KB)

this file i did up today, and again it will stream to the laser but will not send to the controller.

If you would like we can set up team viewer or your favorite flavor of remote, and I can share LB with you.
over all I highlight the shape to send, hit send, it looks like its gonna go waits a second and then makes the game over noise :frowning: and no joy.

  • Have you verified that the IP address of your laser is the same?

  • Do you have other software, like RDWorks, running?

  • Is there another copy of LightBurn running that might have the laser locked? (Press Ctrl+Shift+Esc and look in the list of programs running)

  • When was the last time you rebooted the PC? (Windows update can do weird things if not allowed to complete an update)

yes, I can see the files on the laser. I can also delete files from the laser (created from rdworks and failed LB files). When i attempt to send the file to the laser, it will create the file name on the laser but will still pop up the failed dialogue and the file on the laser contains nothing. I have verified proper function with RDworks but i do not have it running at same time. I have also rebooted the PC a number of times. I can also cut parts on the laser by using the Start Button and live streaming it to the laser, although i never do this for several reasons.

  • Which Ruida controller do you have and what firmware version? I have a 6445 firmware version 15.01.10.
  • How are you connected to the controller from your PC (USB or Ethernet)?
  • Have you tried to format the Ruida internal memory through the HMI? (File; Mem Oper+; Format Mem+; Format in grain)
  • I have tested your posted files.

I have replicated all of your steps and I do not have any issues.

Ruida RDC644XG, Just updated to RDC644XG-8.00.50. RDworks Lab works perfectly, i can send files to the HMI memory. In LB i can send to the HMI memory provided I draw it in LB, if i import a dxf or any other format it will not send to the HMI memory, I can read the controller settings and delete files, jog the laser, live stream, but as of yesterday it will not send to HMI memory. Yes windows had an update before that and yes i did update to latest version of LB. This looks all the world to be a Win10/LB bug. I know 100% it is not the controller as it works in RDworks properly. I have no issues with having a DEV remote connect to my PC and sharing the LB screen with you, unless you have a internal diag log file when it fails. When i do hit send, i notice the screen pauses for a second then errors out., when I draw a shape in LB the screen only pauses for a half second and everything is good. and as before when i send a imported file to the HMI, LB does create the file name but does not send any data to it, leaving that empty file name on the HMI, which then i can successfully delete with LB.

Windows 10, ruida rdc644xg firmware RDC644XG-8.00.53 Ethernet connection
Internal memory formatted through HMI yes,
Everything was working before latest update/ windows update.
Yes I can control the laser completely from LB as well as live streaming to the laser.
Yes I can send shapes that i have created inside of LB to the HMI internal memory
No i cannot send anything that has been imported from outside of LB to the HMI memory however I can live stream these files.
Yes LB will create the File name of the imported file on the HMI but leaves the file with no data on the HMI
Yes RDworks works perfectly and will send to the HMI memory.

LB has been working perfectly the last couple years (or how ever long it has been since first release) It as of yesterday decided to not play nice. No other changes have been made other than LB upgrade and windows updates. the only issues is with imported files, shapes drawn in LB work fine.

The system says i must wait 7 hours before i can reply ??? says i have reacehd maximum replys on first day

  • How are you connected to the controller from your PC (USB or Ethernet)?
  • Have you tried to format the Ruida internal memory through the HMI? (File; Mem Oper+; Format Mem+; Format in grain) please try this step as formatting the internal memory of a Ruida controller via the HMI has been observed to resolve file transfer failures

An idea that may help in the meantime: you can use a USB flash drive.

  • On your PC, Save RD file (to the flash drive);
  • Unplug the flash drive from the PC USB Port;
  • Plug the flash drive into the UDisk USB Port of the Ruida Controller;
  • Load File from UDisk on the Ruida HMI.

There is genuinely no difference at all with files you create in LightBurn vs files you create outside of it. The software literally can’t tell the difference.

If you draw an single line in your art software, export that, import it to LightBurn, and send that to the machine, does that work?

(I’ve bumped your trust level so you can keep posting - it’s a way to prevent spam)

Yep, I created a single line in LB that will send to the HMI memory, I then exported as a dxf, reimport and it will upload to HMI memory, if i import any other dxf i have cut in the past it will fail , if i re import the dxf i just created it will work.

rotorplate.lbrn (95.0 KB)