Just updated new lightburn, now not able to send to laser

There is genuinely no difference at all with files you create in LightBurn vs files you create outside of it. The software literally can’t tell the difference.

If you draw an single line in your art software, export that, import it to LightBurn, and send that to the machine, does that work?

(I’ve bumped your trust level so you can keep posting - it’s a way to prevent spam)

Yep, I created a single line in LB that will send to the HMI memory, I then exported as a dxf, reimport and it will upload to HMI memory, if i import any other dxf i have cut in the past it will fail , if i re import the dxf i just created it will work.

rotorplate.lbrn (95.0 KB)

is there a err log file or anything? I will help in anyway i can short of formatting my pc :slight_smile:

I would just check your network router and settings to make sure that nothing in your network config has changed, and your laser’s IP address isn’t being reserved for anything else on the network. I’ve seen this happen before if you don’t tell your router to reserve the IP address used by the laser, and you don’t have the laser IP address set far enough apart from the others on your network.

My best guess is that anything small enough to fit within a single packet of data (1000 bytes) is going to work, but anything larger fails, but I couldn’t tell you why.

You’ve said “Ethernet connection” - wired or wireless?

wired ethernet, nothings changed in a few years netowrk wise, but i will reboot all networking switched and routers, (there is a bunch) but the laser is on the main switch, as well I can read the settings from the laser, jog the laser, stream to the laser, delete files from the laser. just not send to the laser hmi but rdworks can.

Go to Edit > Device Settings and try increasing the network timeout. It’s possible that it’s just not waiting long enough.

just increased, now it just sits longer before it errors out.

any error logs?

you are on to something, that test file i imported, if i send one of the small circles it will send, if i try to send anythign more complex or larger it errors out

Go to Help > Enable Debug logging, then try sending something. If it errors, it’ll show there, but there may not be much info. Usually when I see this problem it’s just the network dropping a packet. Do you have more than one copy of LightBurn running, by chance?

just one copy, this all happens at fresh reboot as well, where is the debug log located? i enabled it and did a run through

In your Documents folder, called LightBurnLog.txt.

Post here and then delete the file locally. If you run another log it will append to whatever is there.

LightBurnLog.txt (12.7 KB)

this is the whole file this one failed

this is a log of sending a single circle that worked proper
LightBurnLog.txt (9.9 KB)

Did that one fail? It looks like that was successful.

the larger one is a failed attempt,

LB will create the file name on the HMI but when i go to the HMI it shows the name but no art, as well LB shows the file transfer failed

By chance, did a recent Windows Update modify your NIC driver or settings? If you want to see what occured in recent Windows Update, you can open up PowerShell (as an Admin) and use the following command:


When you run this, you will see where the file can be found, opened, and read. You could search for key words maybe (like network, or your NIC name etc)…

So it is the NIC for some reason i cannot figure out yet, This mobo has dual NIC, I plugged the laser direct into the second nic changed IP accordingly etc, and bingo i can now send, so as usaual LB is sound and windows is NUTS!!

That’s bizarre. Looking at the logs, the only clue is that the failed job is not getting a reply from the laser, but there isn’t anything else that’s much different. The first job sent 1100 bytes total, and the second sent 1472 and failed. Is it possible that something lowered your MTU?

I experienced similar after on of the recent upgrades. I found that Lightburn was sending, but was sending no content in the upload because my output selection was turned off. In the “Cuts / Layers” window pane on the right, the green or greyed out toggle was turned off on each layer. This “Output” column is to the right of “Speed / Power” and left of “Show” columns.

This could have been an operator error in a hurry and wild clicking or may have been a config change due to the upgrade. Anyway, I clicked to turn “Output” green and the send feature worked perfectly when it actually had something to send. Good luck.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.