K40 laser still experiencing problems with proper cutting and engraving, as well as stepper motor config issues

Hello Everyone!

I am finally back at working with my modded K40 laser after a brief hiatus… First off… Happy New Year! I thought I should update on my progress, and with that ask more questions with new issues that I am struggling with as well.

I finally rectified my connection problem, (from the NOV 19th post about laser stops working after trying to move it) which turned out to be my initial laptop I was attempting to use. It seems that due to it being a company laptop, there was some type of external USB device block script that was killing the connection when I attempted to operate the laser. I now have a completely independent CPU running the software and have been able to use the laser overall.

With that being said, I have some operational issues now and hoping the forum can assist in solving the mystery.

First item - the laser will not cut or etch a straight line, either x or y axis. The x axis “wobble” or “jitter” is much more pronounced than the y axis, but at 100mms or higher its extremely noticeable. Attached is a photo of what the lines look like, as well as the etching I am going to be inquiring about next.

If you notice, the etching is also very rough on the outline, as well as incomplete left to right. I have tried a number of different speeds and settings, but cannot seem to get this to change. I am at a loss as to what I may have incorrect with my overall system and looking for advice.

additional information:

I have upgraded to a smoothieboard as we discussed last year. I currently have the stepper motor current values very low due to EXTEREME heat in the steppers if I increase them anywhere past about .3. It definitely results in horrible control of the laser with missing massive steps. I find this very troubling as all of the documentation I read states that a value of 1.0 should be good and used almost as a standard. If I set the current value to an .7,the motors seem to keep step ok, but within 30 seconds, the x axis motor is so hot I cannot touch it, running or sitting idle. The y axis motor gets extremely warm but at a much slower rate and the z axis I added gets warm after a period of time as well. I also notice a “bucking” sound occasionally when idle. If I set my current to 1.0, the motors make all sorts of odd noises, run very odd, the “bucking” sound I hear at idle is almost continual as well as missing steps accompanied by extreme heat. ( I get a homing failure regularly) I have a video of the operation at 1.0 but not sure how to post it for reference. I have not been able to find much about what would cause this, and I wish I had a temp probe to give you an idea of how hot the x axis motor gets. It actually blistered my finger (I know, stupid move but everyone touches the stove at some point). I have also attached the config file that I am using for reference. This was a file I got from the link in the smoothieboard website for laser machines, and made a couple tweaks to get the aftermarket screen working. I have compared to other files and the items I would think that relate to the steppers seem to be within standards amongst the community. I am hoping that I made some sort of inadvertent change that would cause the stepper motors to run so poorly.

To circle back to the lack of “detail” of the lines and etching, here are some of the items i tried before throwing the white flag in…

  • checked the x and y movement manually to see if I had any tight spots or irregular movements - smooth and free

  • checked belt tension on x and y axis - not tight as a rubber band but I cannot cause tooth jumping

  • adjusted speeds, increased and decreased for cutting and etching - no change and of course burns through my paper at a very low speed. I am using 200/2 for etching on the paper and for cutting 3mm acrylic, i have found that 5/80 cuts through cleanly. While cutting the acrylic, I have also noticed that it will not cut a true circle and has some bumps along the way.

I attempted etching with both fill and fill + line. I have noted what happens with fill plus line - all hell breaks loose LOL

I am scratching my head and have lost what little hair I had left. Any and all comments are welcome, aside from poking fun at my hair falling out - i have a complex. :wink: I am not sure what would apply to the lightburn software directly, (most of this more than likely does not) or what would apply to the smoothie board and hardware so I am starting here and hope there are suggestions as to what to look for or who to contact to get further along on this.

Thank you in advance for any help!

K40 .7 config.txt (25.1 KB)

A couple things to change:

  • laser_module_maximum_power should be 1.0

  • laser_module_minimum_power should be just below the firing threshold of your tube (maybe 0.02, but possibly higher depending on the tuning of your power supply).

  • You might have a loose mirror or lens

  • Stepper motors can get too hot to touch during normal operation, though if they sound really weird they’re probably not running at the right current setting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.