K40 Using C3D started doing funny stuff

Hello everyone, so been using LB for a while as a few of your know, all has been well but for some reason, the program/machine has started not homing, if I click home the head moves around 15mm forward, and when I finish a job it now sits in the bottom left corner, normally it homes back to the top left.
Not on all files, I’m running will it do this, today same file it homed top left when the home button was hit, so run a frame and it done as normal sat bottom left where I would usually hit home back to top left, but it tried to go bottom left I turned the machine off and closed LB and restarted same again, so turned it off while i sought help from you guys limit stitches work when i push with finger and X & Y will stop, not sure if I have changed something so have attached some pics for reference, maybe I’ve hit a setting by accident but not sure which one if any.
Bit of a waffle i know sorry





Mam Insparational.lbrn (1.4 MB)

Your origin is set at Botton Left, should be at Top Left. Try this.

Hi if I load it to the top left and enter any text it shows upside down, my origin has always been bottom left on LB, cheers


As @ampos says, change your home to top-left (if you have a standard K40).
If you have to mirror and rotate your files afterwards, it is very easily done.

I think you are missing the basics of the coordinate system…

All of these machines ‘home’ on the coordinate system at 0, 0

If your machine homes at the rear/right you are operating in quadrant III

quadrant-iii-home

Home rear/left you operate in quadrant IV

quadrant-iv

The effect causes the art to be mirrored across the bisecting axes. In this case the Y axis, a horizontal ‘mirror’.

There is also an ‘origin’ that needs to be set correctly in the device settings…

Good luck

:smile_cat:

@gixxerboss is correct. C3D boards work with origin at bottom left. They still home upper-left.

This is taken from C3D Device Setup in LightBurn - Cohesion3D:

It’s good to get it clarified, and even better that it even appears in LightBurn’s documentation. :+1:

Sorry, Bernd, I may have given the wrong impression. That’s from C3D documentation about how to configure LightBurn for C3D.

Since using LB I have always had bottom left with no issue, so having trouble figuring out why all of a sudden the top left should be selected, with no adjustments from me on any setting, one day it’s lower left then the next it is top left, ? it doesn’t figure LB documentation on the F1 key does not explain why this would happen.

It sounds strange, your origin should of course not be changed by itself.

Is the behavior with Homing 100% consistent?

The behavior with end-of-job behavior is based on the “Return to Finish Position” setting. You can change XY coordinate to 0,230 if you want it to return to Home position.

It’s not just homing although this is a big issue, today i wasted 5 sheets of ply, i homed and it worked fine homing, then i run a frame and fired the laser as normal to mark the job area out, placed the wood and it then started the job in a totally different area, so trial 2 tried to home it would not home, keeps going forward by 10/25mm so turned laser off shut down LB then connected everything back up, and the head homed,
same again run frame test-fired area run job again different area than was framed, started again this time run job but never cut right through so clicked start again, to run it again and omg it started cutting in a different arear again, after 5 sheets of ply I gave up, there is no fault with laser or home switches as i replaced them just in case. this has gotten me beat, i need to un-do the latest update on LB do you know if this is possible, I think something has changed in the code i could do with rolling back a couple of versions to when all was running good, see if this helps.

You can downgrade but uninstalling the current version and installing an older release:
Releases · LightBurnSoftware/deployment · GitHub

It’s hard to narrow-in on a root cause based your description. Based on loose reading of your observations this sounds like it could be hardware rather than a software issue but not certain. You’d have to take a more systematic approach to the troubleshooting to really narrow it down I think.

Yeah so far replaced limit switches, checked all wiring on the C3D board, checked settings in LB re-done files still the same have now changed to an older version of Lb to check that tomorrow, maybe resetting Lb to default will be next if an older version is not the problem.

And the older version fixed the issue, and dropped back to 1.1.02 machine now starts where it left off and homes back to the top left,