K40 with awc608

So new here but a long time reader. I habe a k40 with a anywell awc608 inside and have been using lasercad with limited success so I am trying laser burn.problem is I burn at max power all the time in lasercad it would work ok but now trying to engrave anything is just max power. So seen a video about using the console to type in $$ problem is with the machine I had to pick to make it work the console is all greyed out I can not type in the box. Also have no fire button to set the % …does lightburn not work the awc608? Thanks for any help on this my trial is about in 10 days so trying to get it done to see about buying it but if it won’t work then I will habe to think of something else
Thank you
Amy and Joe

You need to set up Lightburn properly. The $$ commands are for grbl controllers, yours is a DSP controller and I believe it’s supported by Lightburn as in “Supported Trocen controllers include the AWC708C, AWC608, and TL-3120.” on their website.

Adding Your Laser to LightBurn

You should go though the Configuring a DSP controller. This one’s for a Ruida, but they are both DSP controllers.

You may need to purchase a ‘key’ for that controller. I do for my Ruida, but don’t know about the Trocen.

Thank you for the reply it is setup for Trocen now I guess there is something else going on . in the control panel its set to read the software settings. But if I set it to read the console and set it to 5% …or any number really it still burns at max …cut.engrave.its all the same

I was wondering if I had to buy it to make everything work for my 608

I had to purchase a key, it wouldn’t let me talk to the controller until I got a key, but I really don’t know. If you’re controlling it, then I guess it doesn’t need one. :slight_smile:

There are maximum setting in the controller are more like speed limits. You should be able to set the console the 5% and fire it from the console with the tube producing 5% out. However, mine won’t lase below around 8.8%.

Has this machine ever worked properly?

I don’t know about this setting, I have a Ruida controller, maybe one of the others can help you here.

There has been a few posts on problems like yours. Might want to browse them.

Here’s one of them Power Settings Won’t Adjust

Thanks for the link I have been reading alot on here but I’m stumped now. You ask if it ever worked. Yes it “works” but no never right. In laser cad I can lie to it and get a vector line and a cut line to work and it will engrave but really deep amd dark. In lightburn its just black so I must have something wrong.i have the ttl.pwn.and ground wires hooked up the the controller so pretty sure that’s right . it cuts sample parts out with .001 so it does work but its not right

Not sure what you mean here.

What ttl.pwn wire? If you mean ttl pwm, it should go to the power supply ‘IN’. Did you wire or rewire this?

It sounds like it has never really worked.

If you set the max at the console to 10% and the duration to 15ms, pulse, then go to 60% and pulse. You should see a difference in the dot.

Need to hit the sack, good luck, I’ll check back tomorrow. Good luck :slight_smile:

Ok so using the panel set at 5% 14ma set at 25% 14ma so no change . yes I wired this up and is the following
Grd to grd
Ttl to l
Pwm to l- but I am coming off the ma meter for this one will try and upload a pic

The AWC608 is not gcode based, so you don’t have access to the console. You have a CO2 laser, so you also don’t have access to the ‘Fire’ button - your beam isn’t visible, so turning it on and leaving it on could start a fire or blind you, or both, so we don’t allow it on DSP controllers.

The TTL wire from the controller is the “on/off” line - it tells the power supply to fire. The PWM wire is the one that tells it how strong to fire. Both of those should go to different inputs on the power supply - The PWM wire usually goes to “IN” or “AN” (analog) on the high voltage supply, and the TTL wire goes to “L” (laser).

If you wired both pins to the same point on the PSU, that would trigger at full power all the time.

They are all wired separately .

Hey Amy,

could you post a nice and sharp picture of your wiring on the PSU site and post the type of your PSU (a picture of the type sticker or what it says on it)? Maybe we can spot something that should be different.

Sometimes the physical connection to to the PSU is bad so that the PWM signal couldn’t get all through to the PSU, so you could check the wiring, if the screws are all set properly and if the wires are properly stripped within the connector so that there is a good electrical connection.

And it would also be quite helpful if you could be able to measure the actual low voltage signal of the PWM wire on both the AWC and the PSU side.

Good luck and cheers,

So pretty sure I have been spinning my wheels looking at the wrong thing. Now pretty sure I have it wired wrong those are the pics of the wiring and will take more after work today thank you all so much for helping out with this I love what it has became but the only thing thats original is yhe frame and the case of the laser everything else has been replaced i.e. motors.drivers.board.rails ECT.ect.ect

Your picture shows the TTL line unused.

On the top photo of the power supply, is there any connections to green connector that’s labeled “L-”?

So too left pic the - L is going to the mA meter as seen in the pics last night. And I jumped that side of the ma meter to the awc608 box to the pwm

What??? Don’t do that ! That is probably the or at least a problem The L enables the laser and you
have it enabled all the time.

The ma meter is for HV current from the tube, leave it alone.

Lets try this. This is how and where the wires go the L- mentioned before was NOT hooked up to the ma meter I made a mistake it Was jumped to the fg but is now removed . this pic shows what my power supply says and where its all hooked up to. Looks like I need a wire from th “IN” to the pwm just would like to confirm sounds like we were lucky not to fry this thing

So I want to thank everyone for the help here in this. Problem was the IN and the pwm wire all is fixed now running better than the day I bought it new …it should nothing left of the original. Anyhow thank you all for your help after work I will fix the last pic I posted so maybe someone else will have the same problem on a Google search. Really thank you all so very much

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.