K40 with Cohesion3d problems with my Lightburn backward y-axis

when I home the k40 homes right but lightburn home to x0 y7.874 is there a way to fix that? any help would be appreciated

To which corner does your machine home? If not top-left did you modify the machine or add your own limit switches?

Irrespective of homing location you need to set your machine origin in Device Settings to front-left. I see from the screenshot that you have origin set to top-left.

top left is home

Can you run a homing cycle and then check these:

  1. coordinates immediate after homing (normally this would be something like 0,200)
  2. coordinates at other 3 corners

Appears home is actually front/left.? That’s where everything is zeroed out.

Is that where it goes when you ‘home’ it?


no it homes to back right I want back right to be 00

Which image is the one after it powers on and homes?


Most machines home at 0, 0. This is indicating 0, 200

I would also assume the back/left to be home if that’s where it goes, but the numbers don’t look right.


so how do i fix that

The machine operates in one of the four quadrants.

Most of the time, you have no choice as to origin.

Have you tried setting the origin in the device settings to the front left?

Other than that I don’t know these controllers…


why is to og board 00 at the top left but the new board is 00 at the lower left?

I’m just going by the numbers. Maybe the new board thinks it’s that way. There are many configurable options with that board…

Don’t know what to advise you at this point.

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.