Kerf Offset Bug with Update

I’ve been using Lightburn to cut out some veneers for a job over the past year. Each unit contains 5 closed shapes that are identical and I have 4 units worth set up across the bed. So 20 identical shapes that should all cut the same.

(Apologies for not just showing you the image but my work won’t allow me due to their NDA)

I’ve recently started noticing that some of my veneers are loose fitting. After a while I figured out that it was the same shapes that were wrong, randomly across the array but always the same ones. I checked that all the shapes were still identical and even tried deleting and replacing the problem shapes. When I did this the issue just seemed to move to another group of the shapes. It wasn’t making much sense.

If it had been an issue with belts or steps or loose screws then why is it so consistent until edited? I’d done all the usual checks.

Well, I turned off Kerf Offset and now all my cuts are back to cutting as they should.

Is this a bug in the software since the new update?

I do mostly “marquetry,” cutting veneer pieces to tape together and glue onto another surface. I have identified several things that affect the fit of different wood pieces.

  1. Do an X Y axis calibration to be sure parts turned in different directions don’t change shape.
  2. I don’t use a kerf setting because I have found that each wood species, and sometimes different areas of the same veneer burn differently, changing the kerf with char.
  3. I use “Offset Shapes” and test each wood to see if the offset is correct. My veneers range from .002" to .008" outward offset to fit well.
  4. Orient the pieces in the same direction as the cutout places for them to go into. Don’t try to save material by nesting them where they are rotated. If there is any difference in X Y axis calibrations, this tends to cancel them out.

I hope this helps.

Thanks Patrick, that’s good advice.

The veneers are going into a milled metal pocket so I don’t need to contend with fitting them into another veneer. The tolerances stay pretty precise. I can hold a right and wrong shape together and it is noticeably smaller (1mm or 0.04"). I’m currently kerf offsetting by .15mm (0.006"). I’ll make the adjustments using “Offset Shapes” instead.

Would be good to know why the Kerf Offset was acting up. It worked fine before.

I’ve rolled back the update to version [0.9.24] and the offset works fine. Seems like it’s just a bug in the latest update.

If you think it is a bug, and can replicate it- please send a note to Lightburn developers about it!
Put the word BUG in the title,

The current release is 1.4.03. The 0.9.24 was released a long time ago (April 22, 2021), and many additions and fixes have been produced since. I would suggest updating to our most recent release to see if this has been resolved. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.