Kerf offset produces gcode with superfluous steps

First of all: Great software! I used Laserweb4 before and in comparison this is so incredibly fast, great work and well worth the money!

My problem:
I created a simple project in LightBurn 0.9.07: A circle with diameter 220mm. I set my laser to 1% power and 200mm/s and output the gcode to a file. Then I enable the kerf offset (1mm outward) and again save the gcode.
When I compare the two files, the one with the offset enabled contains a lot of very small steps (~0.03mm) which are only in X or Y direction. In total, the file containing the offset circle consists of about twice as many G1 commands as compared to the non-offset file. This leads to the problem that my poor smoothieboard can’t keep up with the file containing the offset circle and stutters heavily while I can easily laser the non-offset code.
Is there a way LightBurn can produce cleaner code?

Start of gcode for the non-offset circle (without heder for clarity):
G0X151.7Y66.68
G1X148.86Y66.72S0.01F12000
G1X146.04Y66.83
G1X143.24Y67
G1X140.45Y67.25
G1X137.69Y67.57
G1X134.95Y67.95
G1X132.23Y68.4
G1X129.53Y68.92
G1X126.86Y69.5

Start of gcode for the offset circle (superflous lines bold):
G0X151.69Y65.68
G1X151.72S0.01F12000
G1X154.56Y65.72
G1X154.58
G1X157.4Y65.82
G1X157.42
G1X160.23Y66
G1X160.26
G1X163.04Y66.25
G1X163.06

When you do the offset, do you have the ‘optimize’ option enabled? That will help quite a bit:

In fact, there were a couple minor issues with the shape arc fitter that have been fixed for the next release that might also help.

Indeed, this helps. However it only seems to apply mainly to the manually generated offset usind the “Offset Shapes” tool, not the one generated with the “Kerf offset” in the “Cut settings editor”.
Anyway, thanks for your help, looking forward to the next revision :wink:

Ahh - it’s quite possible that I’ve not enabled the post-offset optimization when generating the kerf offset. I’ll make a note to have a look at that.

1 Like