Kerf offset putting a radius on my cut

I draw a 1" square box then add a kerf 0.09 and the preview has a radius. I want a square box with the kerf

I’m assuming this is a screenshot of the preview window. By setting the kerf to 0.09" you’re telling LB that the beam diameter is 0.09". This will offset the actual path from the desired finished profile by 0.045". At the corners it will “roll around” and produce a curved path and a square corner. This is the same with a CNC mill or lathe where the toolpath will similarly “roll around” the corners.

Hopefully this makes sense.

Here’s a graphical example using a 20mm dia tool.


BTW, that’s one big kerf offset!!


Regardless of the kerf size that I enter- if it is a positive number then I get a radius according to the number size. Both in the preview and the actual cutout. The kerf offset works with circles but not squares

The kerf works exactly as Marcus has described above. By leaving it rounded, the machine does not have to make a full stop at the corner, which can make the job run marginally faster, and puts a bit less stress on the machine.

Then your kerf is much larger than your beam, and you’re trying to do something with it other than accounting for beam kerf. If you want an offset, use the offset tool with it set to produce sharp corners. The kerf setting does not give the option for sharp corners.

What Marcus illustrated above is that if your beam is round, and the size of the Kerf Offset value you specified, the cut produced will have a sharp corner, not a rounded one, because the beam “rolls around” the point at exactly the radius of the beam.


That’s exactly what I have been thinking.

1 Like

It’s possible he’s using it to produce thicker lines, or doubled lines, which you can do using sub-layers with different kerf values (I’ve done this many times), but it gives less direct control than just using the Offset function.

Yes, I guess so but I’d go for the offset tool every time.

I follow along with the offset method described above- My new question is when making a positive kerf offset It shows and cuts a radius, but if you use a negative kerf offset- it looks and cuts square.
Also, I don’t recall having this issue a few years ago and an earlier version of LB.

Yes, by making the kerf offset negative you’re telling LB to switch to the other side of the path. This effectively makes my example above an internal corner. Obviously this results in a sharp change in direction.

That’s not a question, it’s a statement. :slight_smile:

Look at the above image. The upper-left corner is the path LightBurn takes when cutting with outside kerf. The red circle represents the diameter of your laser, shown at a few different positions along the path, shown in blue. You’ll notice that it perfectly traces the 90 degree corner as it rolls around it, producing a sharp 90 degree corner even though it’s using a circle.

The bottom-right is what happens with inside kerf. Same circle, but now, to keep the beam inside the square, it has to follow a sharp-cornered path, shown in green. It’s just how the math works out, and it’s always worked this way.