"<" key does not rotate in 1.1.0.4

WIth the “<” and “>” key I used to rotate 45º. Now only “>” (it is “<”+shift) is working: rotate object 45º clockwise.
Using “<” only, does nothing (before, it rotates counter-clockwise)

This note is from the latest release notes:

  • Ctrl and Ctrl+Shift reduce rotation hotkeys (, and .) to 10 and 5 degree increments

I recall Oz talking about making a change to how rotation hotkeys work. The issue you’re seeing may be related to keyboard type. Are your ‘,’ and ‘.’ keys the same as ‘<’ and ‘>’? If not, try pressing the key with ‘,’.

I have a spanish keyboard, and have a single key for < & >. The . and , are on other keys
<> used to rotate 45º, now < does nothing and > rotates +45º
The , & . rotates ±90º so it is not the same.
Can we get back thr 45º with <> ?

Shift +., will rotate 45º.

1 Like

SHIFT+. or +, does nothing for me, as it is “;” and “:”
Try SHIFT+"," it should rotate (for you) -45º, works?
“<” (I have it on a separate key) does nothing for me.

Yes. Shift+’,’ rotates -45º. I’m using standard American QWERTY keyboard.

Ok. In 1.1.03 < > rotates -+45º for me, now < does not work (for me) :wink:

With something selected do the , and . keys rotate it 90 degrees as expected?

The < and > keys were never intended to rotate anything if they are distinct keys on your keyboard.

The shortcut has always been the , (comma) and . (decimal) keys, and then Shift / Ctrl / Alt modified versions of those. On US keyboards, the < and > characters are the shifted versions of comma and decimal.

The fact that it worked for you before was a bug that has now been fixed.

1.1.03
. rotates +90
, rotates -90
With SHIFT, CTRL or ALT does nothing
“<” rotates -45
“>” rotates +45

1.1.0.4
. rotates +90
, rotates -90
SHIFT+. or SHIFT+, does nothing
CTRL+, rotates +10º
CTRL+, rotates -10º
CTRL+SHIFT+, or . does nothing
“>” rotates +45
“<” does nothing
CTRL+SHIFT+> rotates +5º
CTRL+SHIFT+< does nothing

Clearly there is a bug or a feature not working as intended/expected/desiree (by me).
I can not rotate -45º or -5º with keys.
I loved to rotate 45 with <> but no option anymore.
Can we have the key to rotate 45º fot both options/keys?

Hi Oz,
i am sorry - but with my German keyboard the 1104 does not rotate properly, too.
“,” and “.” are ok and with “ctrl” they both rotate only 5 degree. But together with “shift” they do nothing at all.

After you have modified the code to check for the base key scan code, not the character it uses, so the Ctrl+Shift combination should work regardless the code page of the keyboard.
With the 1104 test build it worked, but not with the official 1104. Only CTRL, but not SHIFT.

It doesn’t look like the change for the key-code made it in to the 1.1.04 release. We have a massive rework going on, so I was moving small changes over to that release, and missed this one.

We’ll have another, larger release coming fairly soon for galvo, and the new keyboard rotation amounts will be in that.

Great! I already assumed it must have a simple reason like this…
As you have to touch it again, it would be the perfect occasion to also add the setting for the rotation increment to the settings dialogue - alike the move increments. (5 degr. is a too big step for most of the parts that i cut)

I feel like you asked for that before because the code already uses 1.5 degrees if you hold Ctrl+Shift.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.