KT332 (EC) Control Z and U swap

For those of us with this control stuck With U axis controlling the Z height and autofocus is there a chance we get a button to Replace the Z axis moves with U axis moves? Currently the A axis buttons in lightburn energize the Table but with too much speed. the feeder setup will move the table down, but not up.
Any way we have a 6445 coming maybe that will work better. But we also have two more machines with the Kt332.

The latest (beta) properly ID’s the KT332N now, so I should be able to auto-map Z moves to the U axis for jogging.

EDIT: This is coded now. It’ll need testing, but wasn’t hard to add. Are you interested in giving it a try? I don’t have this controller hooked up to anything with a Z axis yet.

1 Like

Yes I would love to try it we are in production here 24/7. All help appreciated. Let me know what I got to do to try it.

OK. I can now jog the U (Z) axis up and down using the Z axis up down buttons and settings on the mover tab. the problem is my machine is displaying inches. now when I put in 1.2 for the move and .05 in/s for the speed it actually moves in mm. it moves z 1.2 mm and puts 1.2 on the display, but then I can crash my head because instead of 1.2 inches I only have 1.2 mm.

No, I have not crashed we are work in progress here and we have some progress.

Ruida controllers do not understand inches - they work exclusively in mm (technically in thousandths of a mm) internally.

If it’s showing 1.2 on the Ruida display, then it has only moved 1.2mm. If you tried to move 1.2 inches, the Ruida display should show 30.48mm - that’s the metric equivalent to 1.2 inches.

Oz, My Machine display displays inches. My machine moves inches when I command it to move inches. I don’t care what interpolation is going on in the background. My lightburn is setup to display inches on the rulers and my feed is in inches/second. When I jog the table down until the display reads 1.000. it is indeed 1 inch lower. when I use the feeder setup to move the table .2 down it movers the table .2 inches down. When I use the z buttons from lightburn beta you furnished the table slam moves with total disregard for the movement speed selected, and moves the metric amount selected but instead displays the metric amount on the display which is now off by a factor of 25.4 .

so now when i move down 1.0 from light burn I am down 1.0mm and the control thinks is down 1 inch so to get back to z zero the table has to come up one inch which is a crash when you have only moved down 1mm.

X and Y moves are fine, but something is messed up with the z moves. All our parts run without any z are fine. I have noticed nothing else wrong, but any axis moving mm and displaying that in inches is problem.

If you tried to move 1.2 inches, the Ruida display should show 30.48mm - that’s the metric equivalent to 1.2 inches.

Exactly!! I typed in 1.2 INCHES for the move and the table moved down 1.2 mm and the display read 1.2. But the display is in inches. see the problem yet? after the 1.2 mm move the display should have read 1.2/25.4=0.0472

When I tried getting z moves from using the cuts/layers tab and using z offset it does nothing. enabling z in setting menu with relative or abs moves didn’t change anything.

Can you tell me how you managed to get your controller to display in inches?

When I look at the controller display for speed, for example, the display itself shows mm/s after the speed number. Does yours show in/s? If so, how did you configure it to do this?

I don’t have a system here yet with a movable Z axis configured with a harness so I can connect the KT332N controller, but I should have one within about a week, and then I can try this on real hardware, but I’d need to figure out how you were able to get the controller to show inches so I can emulate your setup.



Sorry about the quality, but from the main menu i select screen reference and then there is the unit setting and where you want your stops. Anything you want me to try or do to help I am game. I am not worried about machine damage or screwing up the control. We are not going to mess anything up I can’t fix. We have multiple machines with spare parts coming. Thanks for your time.

edit: also maybe this will help. If I go to feeder setup and select auto feed and feed before setup. When I run, the table feeds correctly at the right speed it just never stops and the display keeps reading U 0.000 However once I hit the stop button the display has the correct position on it.

Have you calibrated the steps per mm (or per inch) setting in the controller for the U axis?

According to your first message, when you used the ‘U axis move’ buttons, it moved the right amount, but ignored the speed setting for the Z. All I’ve done is made it so the Z move buttons now send a U axis move command, but use the speed that you entered for the Z.

With the older version, when you clicked one of the rotary move buttons, did it move the correct distance? The updated version should be sending the same commands, just using the Z speed you entered.

We just restarted machine and It works correctly… If I hit the z move button .1 inch it move .1 inch. and displays it correctly. somehow if you start light burn with a ruida 644g and switch to the k332t ec it does not read right. Sorry but now thats sorted… I have to start lightburn with the k332t and then restart machine but its fine. The moves are just aggresive. when I use the feeder setup the feed rate is right.

feeder setup/ move before cut/ start cut… Z/U moves down continuously and display reads 0.000 till I stop it then the display reads correctly. the speed is fine here.

Z move up/down. I put in .0394 and .1 and both move the right amount, but the move is agressive… it slam moves very fast.

when I try to do Z moves from the cuts/color. it just does nothing…send the file the display flashes but the head does not move and the machine registers busy.

I will try to retest 9.24 in morn.

in version 9.24 I did feeder setup. enable z auto feed/feed before cutting then I put in .2 for the move and 1 time. I then just fill engraved a .2x.2 rectangle somewhere on the table. upon start the table went down at the correct (well smoothly) speed with the Z/U display reading 0.000 till it stopped and then it read .810 which was indeed where it is at. I restarted the machine and did it again same results. Lightburn 9.24 is using the 644xg device.

@LightBurn , You got your test machine wired for testing Yet? Just bumping and checking in.

Not yet - too many things on the go here at the moment.

Bump. Just waiting to see if we need to install new controllers. Have lots of functionality and we are doing work, but a working Programmable Z would put the candles on the cake.

is the fix for the z/u problem in 1.0?

Knocking down production here… would be faster with z/u working… Bump We await. Tx. Anything we can do other than be patient and positive let me know. :slight_smile:

I also have the same controller (KT332N). I’m using the current Lightburn version (1.0.02). I’m able to move the Z table by clicking on the “up” and “down” buttons (I guess it’s the result of the fixes made in the context of this post). I’m working in millimeters and positions seem accurate.

In the “Cut Settings Editor”, the “Z offset” field is disabled by default. I can enable it by enabling the Z axis in “Device settings for …” but it is completely ignored while cutting. Actually, I suspect a real Z move command is sent but ignored. If this is the case, to be consistent with the move up/down buttons, maybe Lightburn should transparently send U moves instead of Z ones when cutting using this controller.

I can assist with testing if you can’t get your hand on this model of controller.

Bump. :slight_smile: Just scanned the updates… lots of other fixes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.