Laser beam will not Pluse

If I try to run a file or “Pluse” fire the laser, I get an error that says “Machine Protected, Press ESC”. I am at a loss what to look for or check. When I started my Nova 24 the ‘Y’ would not move a full stroke. I did a ‘SET FACT RARA’ and that fixed that problem. But the laser will not fire. The Nova 24 set for about five weeks without being used.

Just a quick possibility without knowing your setup,
has the laser got a lid? and is the lid open when you try to pulse? if so there is probably a mag switch that detects when the lid is closed or not, and will not let it fire when open.

Besides the 4 limit switches, which few people use, the Ruida only has two machine protect inputs that I’m aware of… that’s WP (CN5-4) and DRPROC (CN2-3), water protect and door protect respectively.

One of these is not active and preventing the machine from operating.

As @LaserCuttingPro pointed out. It’s one of the two…

Both of these must be low, on mine, for it to operate. Unfortunately there is no led indicator for drprot, but the wp1/2 inputs each have an led that illuminates when active…

You can also go to Z/U → Diagnosis on the Ruida console… this should give you all the states of the ports… in this photo, the Y home switch is active. I think protection on is for the door switch…

I believe these can be enabled or disabled via the machine settings in Lightburn. My door protect was disabled the day I got it…

Good luck


You can also put a piece of tin foil on the lid switch, this will make it think it’s closed.

Most of us don’t have tin foil, if it’s aluminum and isn’t a Ferris metal so the hall effect switches won’t detect it…

If it’s the door switch interlock, I’d just turn it off…


Hi Guys,
Thanks so much for your input. I had the lid safety switch disabled in the system setup. When I did a ‘SET FACT RARA’, it reset the lid setup safety switch. I thought I had at one point closed the lid and tried to pulse, but I guess I didn’t have the lid closed all the way.

But Now the laser will not fire when I run the file

I am not sure what I did but my laser is up and running well :grinning: :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.