Laser Burns Path Durin Traversal movements (Marlin, Anycubic Mega Pro)

So I’m working on a project for a client for my bosses art business. I have everything set up nice and neat in the Gcode file (which is how i have to set up each Print as unfortunately Anycubic mega pro is just not compatible with this or any other program i have found). However, during traversal movements the laser burns the length of the path rather than turning off normally. Ill add the first page or so of movements to see why this is doing what it is doing. If any of you wonderful people would know the fix please let me know. I’ve been banging my head against the wall on this for about a week now.

; LightBurn 1.5.01
; Marlin device profile, absolute coords
; Bounds: X30.64 Y7.3 to X169.36 Y48.74

G1 Z50
G4 P0

; Offset @ 20 mm/sec, 50% power
G6 S0
G0 X32.284 Y118.36 F7800
; Layer C00
G6 S50
G1 X32.274 Y118.954F1200
G1 X32.265 Y122.089
G1 X32.275 Y125.235
G1 X32.295 Y125.882
G1 X32.352 Y126.222
G1 X32.329 Y126.176
G1 X32.245 Y125.934
G1 X32.195 Y125.68
G1 X32.176 Y125.303
G1 X32.151 Y124.607
G1 X32.144 Y123.89
G1 X32.136 Y121.794
G1 X32.148 Y119.675
G1 X32.158 Y119.147
G1 X32.202 Y118.634
G1 X32.278 Y118.143
G1 X32.325 Y117.931
G1 X32.284 Y118.36
G6 S0
G0 X32.374 Y118.955 F7800
G6 S50
G1 X32.365 Y122.089F1200
G1 X32.375 Y125.233
G1 X32.395 Y125.873
G1 X32.53 Y126.682
G1 X32.5 Y126.65
G1 X32.354 Y126.445
G1 X32.235 Y126.213
G1 X32.148 Y125.96
G1 X32.096 Y125.693
G1 X32.077 Y125.309
G1 X32.051 Y124.612
G1 X32.043 Y123.891
G1 X32.036 Y121.793
G1 X32.048 Y119.693
G1 X32.059 Y119.136
G1 X32.103 Y118.625
G1 X32.179 Y118.127
G1 X32.278 Y117.682
G1 X32.317 Y117.58
G1 X32.38 Y117.454
G1 X32.454 Y117.337
G1 X32.532 Y117.239
G1 X32.585 Y117.185
G1 X32.48 Y117.494
G1 X32.442 Y117.755
G1 X32.384 Y118.366
G1 X32.374 Y118.955
G6 S0
G0 X32.465 Y122.089 F7800
G6 S50
G1 X32.476 Y125.231F1200
G1 X32.494 Y125.863
G1 X32.637 Y126.71
G1 X32.863 Y127.088
G1 X32.803 Y127.055
G1 X32.601 Y126.9
G1 X32.423 Y126.714
G1 X32.269 Y126.498
G1 X32.144 Y126.254
G1 X32.051 Y125.984
G1 X31.997 Y125.704
G1 X31.978 Y125.331
G1 X31.95 Y124.594
G1 X31.943 Y123.892
G1 X31.936 Y121.792
G1 X31.948 Y119.691
G1 X31.958 Y119.133
G1 X32.003 Y118.616
G1 X32.082 Y118.105
G1 X32.182 Y117.654
G1 X32.228 Y117.536
G1 X32.292 Y117.405
G1 X32.371 Y117.282
G1 X32.458 Y117.173
G1 X32.553 Y117.075
G1 X32.655 Y116.991
G1 X32.761 Y116.92
G1 X32.872 Y116.864
G1 X32.886 Y116.858
G1 X32.867 Y116.88
G1 X32.688 Y117.19
G1 X32.578 Y117.518
G1 X32.542 Y117.767
G1 X32.484 Y118.372
G1 X32.474 Y118.956
G1 X32.465 Y122.089
G6 S0
G0 X32.576 Y125.23 F7800
G6 S50
G1 X32.594 Y125.853F1200

Typically, at least for CNC-derived machines, this is due to having GRBL parameter $32=0, so the “spindle” remains turning during moves. If that’s the case, setting $32=1 to activate “laser mode” should solve the problem.

If that’s already set correctly, then something else has gone wrong and more investigation is needed.

1 Like

I’ll try that in the console for this next attempt, I’ll let you know if that did the trick. Thank you for the info!

You absolute beautiful human it worked. Thank you so much!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.