Laser connected and accepted file but no imge in window

I am using a Mac book Air, it is connected to my laser, it recognizes the file, I can choose the file on my laser, but when I go to engrave, it is a simple line for a ramp test the laser does nothing and there is no picture of my line on the screen.
As you can see above i cannot save my file on my Macbook Air the save part is grey, i have a Mac desktop that it show the save button which is on my air too, so im thinking it is a computer problem not a laser problem.( But more likely a me problem) i was stuck on this all day yesterday and am desperately needing help. Very New to Lightburn. Thanks so much

On a Ruida you can press ‘frame’ and it will outline the item. Should work with your ‘line’ I do it all the time.

Did you create a ‘device’ profile for your laser?
Ethernet or USB, if USB ensure the driver is the correct one.

Can you ‘send’ the file and run it from the control panel?
Can you ‘jog’ the head around indicating you have control?

On the “Laser” window in the bottom right, it says on the top, “Disconnected” indicating you are not connected to your lasers controller.

Put the mouse cursor on the ‘Devices’ button and right click to re establish the link.

I can’t see anything grayed out, but I’m old… Only system protections would probably cause not being able to save a file, I would think.

Good luck, take care :slight_smile:

Thank you Jack, I did frame and it moved and did frame but still not moving when I press start, it is telling me to press enter again but the laser head does not move when i press start, I did a pulse and that works but won;t throw out a line? Any suggestions please.

If you press start, then have to press enter, there is probably an error message in the LCD display.

I moved the origin near the end of one axes and tried to ‘frame’ a square. The Ruida gave me this error in the LCD. You generally want to 'Esc’ape out to cancel the run.

That line is around 11 inches by the picture. Where is your origin? You have to have more area than 11 inches to draw an 11 inch line. It has to get to speed before it can lase the line. After the line is drawn at the selected speed, it has to slow to a stop. All within bounds. I believe the term is ‘overscan’. The Ruida does this in hardware.

Move the head where it has room and press the ‘origin’ key. You have the software set to ‘user origin’ so it wants to start there. Let us know how it works out.

If your machine is 80 watt, it’s bigger than mine, but the issue still exists.

Good luck :slight_smile:

You may not have the correct rights for this location and need to try a different folder / directory to store these files on the MacBook Air.

I would like you to help unpack this with some more detail, please. How are you connected, USB or Ethernet, Wi-Fi?

What is “it” or who is ‘recogniz(ing)’ what file. How have you tried to run this line, the exact step-by-steps? Did you use ‘Send’ or ‘Start’, and what happened or did not happen when you did this?

Saying, “I can choose the file on my laser, but when I go to engrave…”, would lead me to think you used ‘Send’ and then provided a name for this job, and then could find this named file using the HMI (Human to Machine Interface) panel screen on the laser itself. Is this correct?

Can you connect and process jobs using LightBurn from your other Mac?

Thank you for your help, I cannot connect my Mac Desktop the other computer to the machine, it is too old, which i didn’t realise untill I had downloaded the app. My mac air is connecting to the machine and I can connect using the HMI as you mentioned but cannot save on the computer still, I did try to save files in a different folder but no success.
I have had success now with doing the ramp test I did have to move the laser over and change the origin so I have finally done that but cannot save in my computer still.

Thank you so much for your help that was exactly what it was. I have a lot to learn, Thanks so much

What it file permissions?

I’m glad we could help. :smiley_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.