Laser disconnected after activation

I just bought my lightburn activation for GCode devices. I am using ortur lm2 laser. But after activation, program shows that device is desconnected. I tried everything, maybe someone have any solution ideas?

What i have tried:
Installed drivers;
Installed lightburn again;
Connected and disconnected laser million times.
Also tried to change usb wire and ports.

Maybe I bought wrong activation?
In last few days my win 10 updated, maybe here is the problem? How can i solve it? Thanks! And sorry for my language.

P.s. before activation, during trial period it worked perfectly.

Make sure the correct COM port is selected in Laser window.

I tried all of them…

Make sure your safety stop button is not pushed


Right click on DEVICES button.


Tried both things before, nothing. I thinking, maybe it is not activation fault but windows update? Because just after it I activated program and faced this problem.

There is literally no difference between full version and trial version so I find the timing odd.

Check Windows Device Manager. Can you confirm that you see a COM port that gets created when the laser is turned on and connected?

Is the laser power supply plugged in? My Ortur LMP2 will indicate the USB plug without having the laser itself powered on.

I check, computer makes connection sound and creates com. Yestarday I asked i facebook group same question. And someone wrote, that he have same problem after update - port name and drivers have changed. So maybe someone have any information how i can fix?

Can you provide the following:

  1. Screenshot of Device Manager ports
  2. Full screenshot of LightBurn with Laser window showing
  3. Screenshot of Console window or copy/paste of text with all connection related activity

Yes, windows will dynamically assign com port numbers as devices are plugged in and unplugged, once connected they will stay the same until device is disconnected, once disconnected windows may or may not allocate that port to some other device before you restart laser next time.

Here is photos (sorry, it was faster just to make with phone):

I tried to install a lot of drivers which i found i internet, but nothing helped. Also, I tried other computer, mac - it is working. Thats why i guess, that someting is wrong with drivers. I am using win 10, which driver is best for laser?
I am starting to lose hope.

In LightBurn, select COM3 in Laser window. Right-click Devices button in Laser window.

Does the laser connect?

No :confused: i guess, someting wrong with drivers.

What shows in Console when attempting to connect with COM3? Make sure that no other program is potentially holding the port open. Try rebooting the computer.

Also confirm that COM3 goes away when the laser is not on and comes back when turned on.

It shows what “trying to connect”. I tried to reboot pc few times, also turn on and off laser.
Yes, COM3 goes away in device manager when laser is off or I take out usb.

Can you take a screenshot of Edit->Device Settings?

Here it is:

Looks to me like your laser is configured to the wrong device profile.

Push Devices button in Laser window. Then click once on the name of your laser. Take a screenshot please.

Here it is:

As I said before - before win update, everything was good.

The device is setup as GRBL-LPC. Edit the device and change it to GRBL.

1 Like