Laser does not fire anymore after testing cables!

Hi there,
I recently try to change some longer cables for my EleksMaker A3 Pro. but seems like the new cables didn’t work so I change back the original one. Since then the laser doesn’t fire anymore. After some reading and checking I found that the problem could be in Console the ($30, $31, $32) are missing. It shows (error: Invalid statement) when I try to type them back in. I tried reinstall lightBurn but still the same. So could anyone please tell me how to turn them back on? appreciated for any help!

That’s odd. When your machine boots, it will identify itself with the version number. If possible copy the complete boot message.

This all comes from your controller and is out of Lightburn control. It’s just showing you what it’s getting from your controller. You can try going to ‘Edit → Machine settings’ , it will usually read the machine configuration. Can you do that?

There are people here with that machine, so let us know…



I have managed to upload the firmware Grbl 1.1h to my engraver. Lightburn has found the machine but it still doesn’t fire. It used to fire for two seconds when Lightburn software starts but now it doesn’t. it has no response on the test fire button or the start button. nothing at all.

And the movement seems weird too. The 0,0 is set at front left but the laser go to back left for the 0,0 point. I set the burn area at 250mm x 380mm. But the laser travels much further than that. for example I draw a 10mm square at 20,20mm and send the laser to it. The laser will find the square at somewhere like 100,100mm.

This engraver used to work really well, but it gone wrong when I just try to test a longer cable. and I love using LightBurn too. So I really need some help please. Thank you so much!

Here are some reference:
I use Mac. OS Catalina 10.15.7
EleksMaker A3 Pro.
Firmware Grbl 1.1h

Screen Shot 2021-10-28 at 12.12.46 am

Grbl 1.1h [’$’ for help]
Target buffer size found
Homing cycle is not enabled in your Grbl settings.

You have a number of configuration issues.

Lets go over a couple.

When you set up your machine, you set up the ‘Device Settings’ to reflect the size of your machine as 380 x 250mm. Your machines, “X Max travel” and “Y Max travel” is the X and Y maximum size of your machine.

380x250 and 200x200 elsewhere. You’ve set the machine up in the Device settings, different than in the Machine settings. I don’t think you understand how this works.

You should go over Lightburns Common Grbl setups along with Coordinate and Job Origin documentation. It will clarify some of these issues. It also addresses machines that do not home.

Hang in there :slight_smile:


1 Like

HI Jack,

Thank you very much for your Information, I will spend some time to go through the positioning settings literature you suggest. The reason why I set my machine to this size is just this is the maximum burn area and it worked really well before. But looks like something else has gone wrong now.

The Main Issue now is really that the laser head does not go / switch on. I cannot make it burn at all. Could you please have a look of my attachment and let me know if there are any setting is not correct?

Thanks a lot!

Before you upgraded your firmware, did you save the machines configuration?

After upgrading to to 1.1h, did you restore (write) the old configuration back to the controller?

This is NOT maximum burn area. You want your machine size to be the ‘available’ area so you can get the maximum burn area.

One reason is the head has to be ‘at speed’ when the laser starts to fire until that scan is complete then it has to slow down, turn around and speed back up before it can do any work. If you limit that area you also limit the ‘overscan’ area, which limits speed control.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.