Laser does nothing. ProverXL 4030 V2

Recently bought a prover xl 4030 v2. Also bought a Genmitsu CFL55 Compressed Spot Laser Module 5.5w to go along with it. I am on the second laser now and with both i never could connect. I tried lightburn and lasergrbl. I can move but laser will not turn on at all. Even m8 / m9 does not turn fan on/off.

Am new to lasers but not cnc, cad, or cam. With two lasers not working it makes me wonder if its me or its somehow not compatible. I tried many settings changes and variations. Nothing seemed to help. Any suggestions would be fantastic.

Also if you have a 4030 V2 what laser do you use? Any issues setting up?

If you can move the laser that seems to me that it’s connected.

Can you provide the following:

  1. Full screenshot of LightBurn with Console window in view after connecting
  2. Push Devices button in Laser window, then click once on the name of your laser, then take a screenshot
  3. Screenshot of Edit->Device Settings
  4. Run these commands in Console and copy/paste results here:

As of now it seems to work. The issue seemed to be the wire from controller to laser. It takes a +12 gnd pwm xh2.54 3 pin. The one that came with laser with two female jst connectors was all black. According to sainsmart, One you are supposed to use for the prover xl 4030 v2 is the red black white.
The only other wire that came with laser (red black white) had jst connector on one side and bare wires on other to screw into another. That was for the prover xl (not v2). So i bought some jst connectors and put those on. Laser fires right up.
Never was able to control laser because it did not have proper power and or pwm. Never powered on.
Thanks for the response! Seems to be solved

1 Like