Laser doesnt cut or frame where the job details are

so I just switched computers and downloaded lightburn on my new computer. Nothing has changed with my laser and i havent moved it at all. in the “move” box if i set coordinates for example x=250mm y=250mm my laser will go there. I created a circle in lightburn and just hit frame and it frames the circle from whatever position the laser currently is in. The laser doesnt move to the spot where the where the job details are. Same thing if i hit cut it just starts cutting wherever its at. So basically it recognizes there’s something to cut but doesn’t go to where its suppoed to cut at

Sounds like it is in use current position. But have no experience with ruida controllers.

sorry kinda new to this what do you mean by itsin use ?

There are three different start from modes in LightBurn which are Absolute Coordinates, Current Position, and User Origin.

Here’s our documentation with more details: Coordinates & Origin - LightBurn Documentation

If you change your start from position mode in your laser tab to Absolute Coords, does your laser behave as expected?

one sec checking

that worked thank you so much, quick question when I was framing the laser was trying to go out of bounds but I checked in the device that I have the right X and Y parameters and the job details were inside those parameters

Do this to eliminate a whole bunch of trouble you haven’t yet encountered:

When you start from ‘current position’ the laser starts out at 0, 0:

Screenshot 2024-06-26 at 10.07.57 AM-1

When using ‘absolute coords’, the laser knows exactly where it is:

Screenshot 2024-06-26 at 10.07.46 AM-1

thank you appreciate it

So I did what Ed told me and used my old computer and made a backup then loaded it to my new computer lightburn software. Im still having the issue where if i put the job details closer to the edge the laser is trying to run out of bounds. Also I put the job details at the center of the laser and just made a circle for testing purposes it cuts out an oval and not a circle( tried 3 times)

Double check that you don’t have rotary enabled. Have you changed your machine settings recently? If you cut a 100mm square, does your laser cut it accurately? You may need to calibrate your axis.

‘Im still having the issue where if i put the job details closer to the edge the laser is trying to run out of bounds.’

In your preview window, do the red travel lines show that they are crossing over the green boundary line?

so i did double check the rotary option and its not enabled. I havent changed anything on machine and I havent moved it at all. Only thing I did was change my computer to a new one

Screenshot 2024-06-28 120031
in preview doesnt show out of bounds but right now if I frame it it goes out of bounds