Laser doesnt shut off

I was using Lightburn software trial for about 10 days. I was highly impressed by the quality it was giving me and was about to purchase it, however, I used the “move” function to move my laser at an increment of 1mm. Since then my laser will not shut off after I do a preview of the image (outline size), or when burning the image.
I have tried a new PSU as what i have read which may fix the issue. I have reinstalled the firmware onto the laser board, uninstalled and reinstalled the lightburn software. I went back to the original software that came with the laser (Elekslaser) and it worked fine with that. I still have the same issue.
If I can get this rectified will be great and i will purchase the software. At this stage i have 8 days left of the trial. Please help me with this issue.

We found some issues with the new jogging implementation and some of the weirder Grbl versions, of which EleksMaker certainly is. Just pushed an update. I recommend downloading and installing the absolute latest version and trying again.

Also, you should be able to extend the trial when it expires if you require more time. So don’t worry.

I would also recommend, if you are up for it, installing stock Grbl firmware not the one that came from Eleksmaker. It should be much more compatible with software like Lightburn. We try to support all the documented features but some companies don’t adhere to that feature list and add weird changes.

I updated to the new version today. I was hoping that would fix the issue but it is still there.

What firmware would you suggest for me to update?


Hi Nathan, the recommend is 1.1f (or g), but I have f and it works great.
If you open the console window after it connects you will see the version yu are running displayed there by the “OK”



I’m not sure what i did. I have been sitting here for about 3 hours with beer, uninstalling and reinstalling, playing with settings, disconnecting, different firmware, reconnecting and turning on/off.
I have it back to the way it was and lasering with no issues.

Hopefully it stays this way, and i will be purchasing it when my trial days run out.

Cheers for the help and feed back.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.