Laser don't cut anymore. After upgrade. Ruida 6442S

Hi everyone,
I have an issue I don’t know how to solve.

If I draw a square in Lightburn and select “cut” and send it.
The laser head starts from the top left corner of the square and goes to the top right corner and stops.

From there nothing more happens.
And if I have the laser beam on it just burns a hole at the place.

And I can also inform that I thought it could have been a USB driver issue, and there for I decided that I reinstalled a new version of windows 10 on a brand new HDD. Just to be sure.

When windows was installed I I installed Lightburn and started the laser and connected USB port.
Lightburn find the machine no problem.

And then I draw a square and send it to the machine again.
Same as before, it goes from the top left corner to the top right corner and stops,.
Nothing more happens.

I have reset my machine and also I have put the machine in factory set.

It doesn’t make any different if I use RDworks either, same result.
I put a square down on a usb drive and put directly in the machine.
And from the machine tried to cut it.
But with the same result as before, it stops.

I can also tell that this issue happened after I upgraded RDworks v.8.01.10 to v.8.01.60.
After that everything went crazy.
Now I can’t cut anymore.

Can someone please help me.

//Janne

Hi Janne,

Can you use the jog buttons at the Ruida control panel to jog the laser in X and Y axis without any issues? presumably the machine homes OK?

Can you frame the job?, using the frame button at the control panel?

Did you use “Set factory para”
Or “Set default para”?

image

I don’t think it is a good idea to use either of those - especially not the factory parameters, I have never had to use them.

I suspect some of your Ruida controller parameter settings are missing or incorrect, a good place to start checking is probably your Edit>Machine Settings>Cut Parameters, please screen shot the values and paste them here. e.g. here are my current settings;

Hi NicholasL,

Yes, I can use the jog buttons and also the frame button works.
I used both Set factory para and Set default para.

Yes, like you said I think some parameters is incorrect.
And I it happened when I upgraded RDworks.
After that everything went bananas.

Here is a copy of my machine settings.

How big image can I upload?

Where is ‘cut’ in Lightburn ?


  1. Does it home and boot ok?
  2. Is there any kind of error message on the machines console ?
  3. Are all the motor drivers green lights (not red) illuminated ?


Are you 'send’ing it or 'start’ing it ?


I think we’ve brought the crtl-alt-delete or re-boot if something is wrong… Although it’s sometimes the only procedure, it should be the last, especially with ‘factory’ type resets …

I got my machine, got connected and saved the current machine configuration… That is what should happen for every user, it is easy to recover via software from any problem with configuration. This should be in the manual you get with the machine…

I’ve heard this song and dance before… :face_with_spiral_eyes: I don’t know of any software that loads and writes junk to your controller breaking your machine ? something else happened…

I don’t think the software can determine the controller type, unless via the firmware versioning.

Also as a general rule, don’t upgrade software unless it contains something you want or need. Such as a smaller file size with .lbrn2 files. Same with firmware, if it works don’t mess with it…

You have a nice laser, we’d like to see you enjoy it… we’ll help you all we can… try and change as little as possible each change adds to the confusion…


Most of your configuration looks as if it should be functional… However I wonder about the setup… It shows both the U and Z axes have homing enabled… Are you using both of these axes?

I enabled my U axes and it still booted ok, so it may not be an issue, but it seems odd that would be setup that way…

If possible, connect via Ethernet…

:smile_cat:

Thanks jkwilborn for your time,

The head goes home as it should and boots perfectly.
And there is no error messages.
Also the motors drivers light shows green.

I changed configuration for U and Z axes and turn them off but with no different result.
I also like you said changed to Ethernet connection but that didn’t help.

I also tried to insert a file to the controller and try to cut it from machine directly. But no :disappointed:
The reason I rebooted like everything was my last chance to start all over.
Of course I started with reinstalling a clean version of Windows on a new HDD.
And then I installed Lightburn.

I have used the machine for about 3 years now and I’m really happy with it.
So this was a kind bad day for me :disappointed:

Now it’s a new day here in Sweden, so I have to start all over again.

Any suggestions where to begin?

And again, thanks for your time and effort on my problem :pray::blush:

We need to find a common issue that will point to the problem area.

Do you have any kind of voltmeters or anything you can use to check some of the simple items… like the connection to the lps…


If this has been working, and by your description, I’m not thinking software… I’m leary of pointing a finger at hardware…


If you do the square at another location, does it do the same thing?

If it works in a difference location, maybe something related to the drag chains/internal wiring… if not we need to look elsewhere…

The Ruida has an ‘err’ indicator on the controller that indicates and internal hardware error… Have you check that after a failure?

Generally, the most logical thing to fail is something mechanical and that can include wiring in the drag chain or connectors…

Take a few minutes and ‘gently’ tug on the controllers wiring to ensure they didn’t stick the wire in, glue it and move on… Sometimes they forget to screw it down … works for a while then…

:smile_cat:

Hi jkwilborn,

I have turn the square in every kind of directions and like you said also now check all wiring.
But the head just stands still. ( but if I hit the Frame button on it works perfectly )
The wiring is perfectly done and nothing is loose.

And the Ruida controller shows no error at all.

The funny thing is that if I use “scan” mode and increase the speed to like 400.
It doesn’t matter the laser head moves like it should but very very slowly.
Doesn’t matter how much I increase the speed.

And I saw now that if I use “cut” mode the laser head kind of moves a half of a millimeter ( 0.0197 inch ) when I hit start and goes back the same when I stop.

It kind of sounds like when I hit start the machine get the info about cutting but there is a weak sound the I feel holds the head in it’s place.

The strange thing is just that the maskin always worked perfectly.
But after upgraded RDworks 8.01.10 to 8.01.60 everything stopped working.

I mean, I just started the new RDworks version and put up my work and started to cut.
And nothing happened. So strange

Even though like you said if it works don’t upgrade. My fault, Sorry😞

As I stated, it more than unlikely that the new version of RDWorks would write junk to you controller.

Can you move the head around the problem area without any ‘binding’ using you hand?

:smile_cat:

Hi jkwilborn,
sorry for the delay.

Yes, I can move the head around with no problem ( the machine off of course )
I just had a conversation with the manufacture of my machine and they can’t figure it out what the problem is.
They told me that the only solution is to replace the controller and the motherboard.
And also I have a Ruida 6442S and the told me to replace it with a 6445S.

They told me something had happened when I upgraded RDworks 8.01.10 to 8.01.60.
Because they think that my unit isn’t compatible with 8.01.60.
But for me it sounds very strange.
Like you said, the software can’t damage your hardware, it just mess upp the settings.
But that you can fix.

So now I’m kind in a dilemma, should I keep looking for the problem or should I buy a new set of controller and motherboard.

And also, I tested today to shut off the air supply just so I can hear what’s happening when send something to the laser.
And even if the laser head never start to move you can hear the two motors start and want to move but they don’t.
But if I hit the “Frame” button on the machine it works like it should. Weird!!

Did you possibly upgrade the firmware while upgrading RDworks?

Can you check what firmware you’re currently running?

This sounds like a configuration may still be able to solve this. Have you carefully worked through the configuration?

Have you watched Russ’s videos on recovering from configuration issues?
RDWorks Learning Lab 74 Disaster Recovery - YouTube
RDWorks Learning Lab 77 Vendor and User Files - YouTube

I agree with @berainlb … I think you should look closely at the configuration before doing any hardware changes… These controllers are really pretty tough as far as dependability.

I think the console of the 6445 is a little larger than the 6442 and you may have to modify the cabinet for a ‘fit’. Roll your mouse over the image and it’s controller is identified… The first is the 6442 dimensions.

Worst case, before a new controller, I’d suggest an attempt to update it’s firmware… At that point you have nothing to lose and I’ve seen them resurrected doing this… it is a ‘last’ chance type of fix… so I wouldn’t suggest it unless you are going to replace the controller anyway…


Do you have any electrical knowledge, like a voltmeter?

:smile_cat: