Laser fires during frame & home after lps upgrade

First off, thanks to everyone in this community for the amazing wealth of knowledge that is shared here! I have learned so much just poking around.

I’m still fairly new to the laser cutting world. My partner & I love building things, and we purchased a red & black generic Chinese 60w laser cutter about 3 years ago. We’ve had a relatively smooth journey so far, and there are thankfully plenty of skills that translated well from other hobbies like 3d printing, vinyl cutting, digital vector graphic design, and Arduino & other electronic/soldering projects.

I’m pretty confident in my knowledge of the basics on the laser, but have finally hit a problem I can’t figure out. Honestly I really enjoy the interface of the community here, and it seems much more active than /r/lasercutting which is where I learned most of what I know so far.

Starting Configuration:
60w Red and Black Laser
Upgraded CW5500 chiller
Upgraded Extraction fan that’s quieter than the previous jet engine one
Ruida 6442G controller / MYJG60W LPS

Everything has been running beautifully for the last several years… Except for the time the old extraction fan pulled too much amperage through the plug on the laser and melting the fuse from the wall plug in the back of the laser… And having to replace the water flow sensor when it randomly stopped working. But those were fairly straight forward to sort out.

We’ve been wanting to upgrade the tube from 60w to 100w for a while. Mostly so we can cut through some hardwoods that it currently struggles with (2mm Purple/Redheart). We researched a lot over the last few years, and made sure to get the right chiller when we upgraded that earlier. Recently we’ve noticed that the output on the laser has been steadily decreasing, so we decided to go ahead and do the upgrade.

We tried replacing the power supply first/ before messing with the tube.
Upgraded from a MYJG60W LPS to a Cloudray M100.

-PROBLEMS START- Had to re-connect the high voltage to the tube. Not a huge fan of that process, but it’s on there solidly with an rtv silicone and tubing cap. The other (less terrifying) wire is just reconnected with a wire nut. It’s on/reconnected, and the laser still works…

But now it fires while doing a “home” or “frame” command, both via PC/LightBurn and directly from the controller screen.

After reading and watching every video I can find, it seems likely that the “L” port on the power supply may be bad. A few Amazon orders later, and it’s the same thing with two other new LPS: MYJGG100W & CLOUDRAY DY13

Well, maybe I messed something up on the tube? Went ahead and put in the upgraded 100w tube. (I know introducing a potential new set of problems isn’t the best, but I was out of ideas.) I 3d printed an extension box and low profile mounts to get it lined up with the current mirror height. Lined everything up, and got a nice focused pulse test dot.

Same thing. It’s firing the laser (at a low power) when doing a frame or home.

I then replaced every wire and end crimp in between the lps and controller. No change.
Upgraded the controller firmware. No change.
Reset to factory parameters. No change.
Checked that it’s set to “Low” instead of “High” in the vendor settings.

I’ve been down every forum post I can find, and here’s where I’m at:

  • PWM is set to a low value by the machine while doing movements between cuts
  • The L-ON1 connection from the Ruida controller, connected with the L port on the power supply is supposed to tell the laser when to engage.
  • The LPWM1 connection on the controller tells the LPS what “percentage” to fire at (I know it’s not exactly that simple, pulse width and all that).
  • The L-AN1 connection on the controller can be used instead of LPWM1, but it’s the analog version, some configurations I’ve seen use L-AN1, and some (including the original wiring in our machine before the LPS upgrade) use the LPWM1 connection.
  • All of the connections on the controller side of the LPS wires are outputs, and the connections on the LPS side of the connection are inputs. The LPS is expecting “Fire / Don’t Fire” from on it’s “L” connection, and “How strong should I fire” on the “IN” connection.

When I do a “Check TL” test on the controller panel, I get “Power 1 Communication Failed”, but I haven’t been able to find much documentation on that particular test.

When I cut something, it will do the full cut, but leaves a ghost engraved line between shapes.

My current top suspect:

  • I think the L–ON1 port on the controller (or the connector), or the L-ON logic on the board is dead or messed up.

The same thing happens with multiple LPS, multiple tubes, and completely new wiring. I would definitely prefer this to NOT be the case because controllers are expensive, so I’m hoping someone can help with any new ideas or troubleshooting to try!

I haven’t done any multimeter testing so far, since my electronics experience is firmly in the “not hooked up to any power” category. I think I have one, and can use to troubleshoot if needed, but I may ask some really basic questions on using it.

I also went down a 1am frenzied rabbithole trying to use the CN6 port on the controller, enabling only “Laser 2” to see if it’s the L-ON1 connection for just CN5. I wasn’t able to get it to fire at all that way, but it wasn’t the most coherent attempt, and I couldn’t find documentation on anyone using that configuration, so IDK if it would even work in a perfect world.

Thanks in advance for any help!

You have also connected the controller’s GND terminal to the HV power supply’s G terminal, right?

One further test:

  • Disconnect the L-ON wire at the controller
  • Connect it to one of the +5V terminals at the controller
  • Run any of the failing jobs

Because the L input at the HV power supply is now pulled solidly high at the controller, the laser tube should not fire at any point during the job. I assume the neighboring H terminal is not connected to anything.

If it fires, then the problem is in the power supply, which seems unlikely given your tests with multiple supplies.

If it does not fire, then the problem is in the controller, which is what you didn’t want to hear. :sob:

1 Like

Ah! Oops :sweat_smile:, I meant to include this in the original post:


Nothing connected to H on the LPS and the grounds are hooked up.

I gave it a try with L-ON1 connected to one of the 5v pins on the stepper motor connections on the controller (nothing connected to L on the LPS).

No cutting (on frame/home) or when running a job.

Dang. Thanks for giving me a way to confirm though!
Now off to hunt for a new controller :money_with_wings:

No, that’s backwards.

You want the L pin on the power supply pulled high. The easiest way to do that is to disconnect the other end of that wire at the controller from the L-ON terminal and move it to a `+5V’ pin on the controller.

Then the laser tube should not fire at any time during the job.

Oh geeez. Yep, that makes sense. I think my last brain cell tried to take a vacation.

Just tested with L-ON1 connected to nothing, and L on the LPS connected to the +5v pin on one of the stepper motor connections.

Same thing, it’s not firing at all.

So if I’m understanding correctly, the controller should be putting out a +5v output on the L-ON1 pin to tell the L connection of the LPS “Hey don’t fire”.

The controller isn’t sending anything on the L-ON1 pin, and because the mode is set to “Low”, no voltage means “Fire ze lasers!”

Testing with the +5v connected to the L on the LPS verified that the LPS can receive the High (5v) input and understands that correctly as “Don’t engage”

Did I keep all that straight?

Definitely seems like the hole is in the controller’s end of the boat.

Alas, yes.

The controller output is an “open collector” transistor that’s turned on to pull the L-ON pin to ground (a.k.a. common) when the laser should fire. The power supply has an internal “pull up” resistor from the L pin to +5 V that (wait for it) pulls the voltage up when the controller doesn’t turn on the transistor.

However, if the transistor is damaged and can’t be turned off, then it holds the L-ON signal low all the time and the laser tube fires all the time.

You’ve verified the power supply does not fire with the L input high or not connected. Thus, the controller transistor is keeping that signal jammed low.

A note of caution is in order.

The output transistor is intended to pull the pin low with a device connected to the positive supply.

When you connected the L-ON output directly to the +5 V pin, there was no device between the pin and the power supply, so the transistor tried to pull the supply low. This is an excellent way to kill transistors (ask me how I know), so … never do that again. :frowning_face:

1 Like

:grimacing: Gotcha! Thanks so much for sharing the great info!

I should have the replacement RDC6442S tomorrow. Looks like I’ll be able to use the same screen, so it should be a straightforward swap :crossed_fingers:

Back up the current controller settings before swap.

1 Like

Backed up the 6442G vendor settings in RDworks, swapped in the new board, and loaded the settings to the new 6442S.

:tada: It’s working perfectly now! :tada:

Gonna close it up and pretend I didn’t notice the pins for controlling a Z and U axis lol.

Thanks so much for the assistance!

1 Like

Excellent choice! :grin:

Glad to know you’re back in business, too.

Up in the first post, you mentioned trying the Laser 2 port without success. That should work, although it also requires a matching LightBurn configuration to tell it which laser to use, and might make an interesting project for a day when you have nothing better to do.

You could run the controller on the bench with LEDs to show its outputs to the nonexistent HV power supply, disable all the homing & suchlike, connect it as a separate machine, and explore the configurations until the LEDs blink merrily away.

1 Like