Laser fires permanently - PWM problem?


I am Matthias from Germany - an enthusiast in medieval arts and crafts … I am neither a native speaker nor good in electronics or programming. So please excuse any stupid expressions or questions :o)

I am absolutely new in laser cutting. I just anhanced my CNC mill by a laser module.
It worked fine for a short time. I managed to engrave text and to cut an “O” from a 8mm beech plywood board.
When restarting the machine I recognized, that the laser fired for a second in the moment when starting lightburn.
Some days later - meantime I didn’t touch and I didn’t change anything - the laser fires permanently on full power when switching on the controller - lightburn not running yet. Even when starting lightburn, M5 won’t shut it off.
I tried many different things:

  • flashing firmware again
  • changed grbl settings: e.g. laser mode off etc.
  • altered connection (I thought of wrong wiring)
    - I disconnected the laser driver from the seperate power adapter (see image) and tried to put
    24V to the 4 pin input plug - laser doesn’t fire at all.
    - When I unplug the connection to the xpro and start the power adapter, the fan of the laser
    module starts, the laser does not fire. Therefore it seems like the XPro permanently sends a
    PWM signal in full power.
    - Also unplugging the “second” ground wire between the laser controller and the XPro didn’t
    change anything.

Nothing helped. That’s really dangerous and frustrating, as now I can’t use the machine at all.

Here are my settings:

  • Controller GRBL XPro V5 Spark Concepts; Firmware for laser mode CNC_xPRO_V5_XYYZ_BM3D_NC
  • Laser module Ortur LU2-10A 10W
  • Laser controller Board La_Conv_V1.0
  • One power adapter for Controller and laser: Kingwen 24V 20A Adapter Transformator 480W
  • Controller GRBL settings that once worked well:














































Maybe I do not need the laser module controller board? But if so, how to connect the module directly to the XPro controller? And most interesting: Why did it work once???
I am almost sure it’s something simple…

Any help would be appreciated.

Thanks a lot in advance


Check the pwm with a voltmeter. You can remove power to the laser and just read it from the controller. If it has voltage on it the laser is probably firing… if it’s stuck at 5V that’s the problem.

PWM is a ttl signal in the range of 0 to 5V. If you read the voltage at the pwm pin, relative to ground it should be the percentage of voltage…

If it’s 50% pwm you should read 50% of 5V or about 2.5V, 20% about 1V…

Good luck


Hi and thanks!
The current between GND and PWM is 1.33V. I understood that it should be 0.
Any Ideas how to fix this?

Thanks again in advance!

The laser can be causing it or the control board.

You will have to remove the cable from the laser or control board and measure it without the other component.

Isolate the control board from the laser and measure the control board.

If it’s not supposed to be lasing, then it should be 0V.

If it’s the control board you need to ensure you have it configured properly for a laser…

Good luck


Hey there!

Thanks again. I am a bit farther - just to run into the next problem.

  • I managed to control the laser on/off by leading the pwm through the relay (see image below)
    Now I can use lightburn for engraving.

The next problems:
1 As soon as I start a GCode, the laser starts firing as soon as it moves (in G0) instead of first moving to te engraving starting point and then starting the laser. Using the “Fire” button on 0.25% starts the laser on high power, burning everything underneath. I guess the root caus is the same as before: The PWM sends permanently 1,33V instead of 0 when not activated.
2. New motion problem: Really surprising is, that engraving a circle actually ends up in a narrow elipse. The y axis seems to go way too far. When I order any axis to move, let’s say 50 mm, it does so perfectly - but not when a GCode file is running.

I really don’t understand what could have happened since it worked in my first test. Neither the PWM problem nor the offset problem.

Any help is appreciated


A relay isn’t going to be fast enough to work properly with the laser. You should not need to do this.

If the control board is producing any voltage when the laser is supposed to be off that’s a problem.

Generally this can be caused by the $32 set to laser mode. I know yours is set as I saw it in your first post.

Either the controller is not configured properly or it’s broken…