Laser firing moving from origin to where the work starts

Hi all new to this forum. At the moment i am rebuilding a Trotec 100 x 60 cm with a 80W laser tube. Have switchet to a Ruida 6445s controller and is running lightburn. Re used power supply - driver - motors on X and Y axis - Z axis had a 220 V motor mounted - so i switched it to a Nema34 closed loop. All 3 axis is now up and running. The old laser tube was totally gone a lot of black spots inside it. So decided to change both psu and tube, waiting on new brackets for tube, so testing with the new psu and the old tube. Now my problem started. Wiring made : Ruida LPW to PSU In. Ruida L to PSU L. Ruida Gnd to PSU G and one side of the water protection switch.Other side of the water protection switch to PSU P. Laser 1 is set to “active low” using the L input of the PSU. Laser 2 disconnected in Ruida settings. Starting up all 3 axis runs homing Top left corner and Z axis in top no problem. all 3 axis can be manually moved through Ruida controller or through lightburn no problem laser stays dead through these movements. Then i load a job either through " file" on Ruida or in Lightburn and start up. Laser fires immidiately from 0,0 and draw a line to where the work starts also between moves during the proces and after job done it makes a line back to 0,0 ?

You might try switching the TL and TH wires on the power supply unit. I had a friend who wired his PSU backwards and he had the same problem.

Ah and then switch in Ruida from “active low” to “active high” That i will try tomorrow damn work breakes in taking all ones freetime.

Take your voltmeter and a minute, measure what’s going on between the Ruida and the lps.

The laser is on when L-ON1 goes low. Since the pwm runs continuously, that’s not it.

Without the lps, you should be able to just measure L-ON1at the controller (or L on the lps) for proper operation.

If it is low or stays low, that’s a problem. It should be high until the machine needs to lase.

Just because the lps is new, I’d be suspicious.

If you move it to ‘H’ and invert it, you should have the same issue… if not it would indicate a hardware issue with the Ruida, I doubt that…

If the water protect is wrong, it shouldn’t fire.

Figure out what’s wrong and don’t spin your wheels… Don’t rewire anything unless it ends up really being necessary.

Good luck


I forgot to mention - when the job starts on the PSU the leds stays dark the green and yellow one. And trying to use the bottom on the PSU “fire” it won’t fire. I did some rewiring - dismantled the input to the PSU P from the water protecting switch and rewired it to the Ruida controller WPT1. Left the PSU P port without connection. Configured the water protection switch 1 “true” in Ruida setup. If i pull the 220V plug for water pump WPT1 activates in Ruida panel. Replugging it the fault can be reset. Now when starting a job it runs as it should, The leds on the PSU the green and yellow one flickers when laser fires. And the “fire” buttom on the PSU works. But still i am wondering there must be a issue - atm leaning mostly to the new PSU. Trying tomorrow with " active high" and the PSU H and rewiring WPT to PSU P - to check the PSU.

This is probably the best way. Instead of it suppressing the lps it will stop the controller and allow you to fix the issue and continue.

P input is the water protect for the lps.

These are both inputs…

Did you miss the explanation of how the lps interfaces and how to check it?

I’m willing to help, but not if you keep changing the wiring around. I think you had it wired correctly in the first place. Now I’m not confident what you have with the hardware or the firmware.

Good luck


Hi I am pretty sure I had it wired correctly - and thats how I wan’t it to end up. As I see it it can be 3 different things doing this. Ruida giving something wrong out on L - something has a influense from outside to the wire connecting Ruida L to PSU L - voltage flickering - Or something is wrong with the new PSU. When i bought this 10 years old machine - it ran but with a lot of issues. Gogol controller card connectd to a PC through 2 D sup cables. After finishing a job and returning to 0,0 it sometimes keept hammering pass Y limit ( had lost machine coordinates ) Thats why it’s now is a Ruida controller. It wasn’t possible to lower power on laser - found solution here during dismantle - seems like laser tube is gone and to keep it running previously owner had made a connection on the PSU from +5V direct in IN. No wonder it wasn’t possible to reduce output power

Did you miss the explanation of how the lps interfaces and how to check it?
Keept output from Water protection switch to Ruida WPT1 - and meassuring with this setup to locate the problem.
Hope i am correct here - on the PWN output i meassure the correct value with the voltmeter 50 % power it shows 2,5 V steady. So agree no prob here.
Plugged in on the PSU during standstill i measure 4,6V - and during a work around 0,2V seems correct to me - Started a job unplugged just measuring output from Ruida and the wire to the PSU i also measure 4,6 V during standstill and 0,2 V working output - Tried measuring direct on Ruida CN5 unplugged - but warning cuts in on panel as it should do unplugging wpt1 input signal. Leaning more and more to a defect or weak PSU

Rewired everything back to starting point output WPT to PSU P - disconnected WPT1 in Ruida controller.
Unplugged the adapter in the PSU: Measuring between G and L standstill 4,6 V - running a job measuring between G and L 0,2 V seems correct to me.
Plugged the adapter in the PSU: Running a job meassuring between G and L again 0,2 V. But measuring between G and L with adapter plugged in the PSU the voltage is only 1,3 V in standstill - Hope i am correct now with my conclusion - Something in wrong in the PSU ???

The first measurements seem ok, then you have a second set…?

I can’t really tell what you are doing. It sounds like you are connecting them or?

The WP1 is an input!

The WP1 is the input to the controller to determine if the water is flowing. It is active low, being pulled low by the water protect switch. The P input to the lps is the ‘other’ way some machines implement the water protection. The drawback is that with a water fail, the controller will continue, since it doesn’t know that there was a problem with the water.

In the end, you want it to go to WP1 from the water protect switch and wire P to ground as the protection is being done via the controller. If you have a failure, the controller will stop everything and allow you to fix it and continue. Using the lps P input for this will result in a loss of the job and materials in all likely hood.

The L-ON1 turns the laser on and off. The value you are reading, 1.3V is below a logic ‘low’ I’d say it’s being enabled. Not plugged it’s the proper ‘high’ state.

If I’m following you when you re-wired it, you now don’t have a ‘high’ on the L terminal?

If so it would seems to be the lps, however the earlier post is contradictory, like you made a mistake in the rewire, which is why I don’t recommend random rewire.

Some of the measurements you state, I have no clue where you are measuring them from the earlier post. I know you know where you are measuring them.

I’d contact whomever you purchased the lps from and advise them of the low voltage on the L terminal when in ‘idle’ mode and that the controller is showing a ‘high’ state when the lps is unplugged from the controller. I’d give them the voltage readings.

Sounds like the lps has a problem. You did run LPWM1 to the ‘IN’ of the lps…?

Good luck


Hi yes it is back to, im my eyes the correct way to wire the Ruida to the LPS.
Ruida GND to water protection switch and input LPS G.
other side of water protection switch to LPS G.
Ruida L-On1 to LPS L.
Ruida LPWM1 to LPS IN.
It is with these connections I meassure the drop from 4,6V to 1,3V Between LPS terminals G and L 4,6V with adapter unplugged from LPS and 1,3V plugged in LPS.
The first set of measurements was with output from water protection switch wired to Ruida controller. The ones that seems OK.
Second set was with water protection switch wired to LPS P. Where it fire from 0,0 during job and back to 0,0 job completed

Hi no keept it “active low” in Ruida

This is how i rewired it earlier.
Ruida GND to water protection switch and LPS G.
Second side of water protection switch to Ruida WP1.
But without wiring LPS P to ground.
This was my first set of measurements the ones that seems ok.

When I say ground, I mean the system ground which should include all of the parts. This is the common reference for all the signals being passed around to the different parts.

The wp ‘switch’ has one side to ground and the other is the ‘signal’ that goes to ground when the switch becomes active.

The water protect (wp) can be handled in at least two ways.

You can do the low cost, poor mans controller way of wiring the water protect with the ‘signal’ wired to P (water Protect) on the lps. It’s not the way to wire these up when you have a good controller, as I’ve explained.

The Ruida is designed to handle this issue and maintain control over the operation. It is best to wire the ‘signal’ line from the wp to the WP1 input of the Ruida.

When you do this, you must wire P of the lps to ground.

There are three simple connections to the lps. Do you have these?

L-ON1 → L
P must be help to ground since the Ruida is handling the wp system.

Ground → Ground - you need a common reference for signals.

Am I/you missing something?


This is the set up that pulls the voltage down to 1,3V during standstill.

This is the setup that keeps the voltage steady at 4.6V during standstill - but with P of the LPS floating meaning i haven’t grounded it to system ground .



No thats the one i haven’t made - trying that tomorrow morning
Ty a lot for helping me it means a lot - must admit my circles are getting smaller and smaller meaning pulling a lot of hair out atm

That’s ‘held’ to ground…

Just stick with a methodical approach and we’ll figure out what’s going on… and you’ll be back up in no time.

You do need to pull P to ground on the lps. Mine has just a jumper to ground on the lps.

Good luck


Oh it haven’t been up running - bought it around 2 months ago - seller couden’t do it so to expensive for him with so many issues - gogol controller card hammering sledge pass Y limit into the backwall - bearings defective on X axis sledge - water system alive (algees) - lense and mirrors burnt - laser tube with black spots inside it - 220V motor on Z axis so no control here except manual measuring. Everything is done now except that damm LPS bugging me

Yup as expected - moved signal line from wp to WP1 input of the Ruida.
Wired P of the LPS to system ground.
Measured voltage between G and L on the LPS it’s 1,3V in standstill and laser fires again from 0,0 when job starts - movements in job and back to 0,0 when job is done.

If i remove this wire - meaning P of the LPS is floating - I can measure 4,6V between L and G on the LPS in standstill.

Pretty sure now it’s a new LPS.

YIKE YIKE YIKE It was the LPS gone haywire. Sometimes one’s mind take full stop - after this morning measurements I suddenly remembered i had the old LPS laying - was sure it was defective - since old owner of the machine had made the connection LPS out +5V direct in IN on the LPS forcing the laser to run at 100% all the time. So remounted the old LPS with correct wiring.
Suddenly i can measure 5,05V between G and L on the old LPS in standstill and 0,2V during work.
Again TY a lot for the help Jack - all left now is the decission to use the old LPS or get a new one

I was suspicious it was the lps. The Ruida are pretty tough animals and all the signals seemed good for proper operation. I warn against suspecting hardware, especially wiring when something has worked… You’re doing a pretty major modification.

I think you complicated it by changing the wiring around.

You don’t learn this stuff via osmosis. I still have lots of questions about how the Ruida actually works :crazy_face:

I’d contact the manufacturer or wherever you purchased it. If the old lps is working why change it out?

Take care