Laser gets stuck halfway, but only in line mode

Hi there, I’m using LightBurn 1.5.06 on Ubuntu 24.04, with my Atezr L2 36W.

Somehow the laser would get stuck on my vector file. It happens every time, but at various moments, usually within the first 5-10 seconds. It doesn’t seem to happen with other files, also not if I switch the layer mode to “Fill”.

When the freeze happens, the laser is switched off, but the air assist continues to blow air until I power the whole thing off. LightBurn doesn’t report any issue in the log and everything looks like it continues to work until I click Stop:

Project loaded in 2 milliseconds
ok
[VER:1.1h.20230501:]
[OPT:VNZHDLI,254,2048]
Target buffer size found
ok
<Idle|MPos:0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>
ok
Starting stream
Layer C00
k
o

Please help.

My failing .lbrn2 project is attached below:
logo.lbrn2 (69.7 KB)

If the engraving proceeds normally in the preview window, I would pay attention to the USB cable. Check that it is well connected and stable. And if it don’t have a ferrite core, replace it with one that does.
I’ve had several communication and data transfer problems between machines and the computer and changing the USB cable solved them.

is this actual output of your console window, that ko is odd and denotes possibly a communication issue.
as @Kuth suggested trying a different USB cable or, a totally different line work just for sanity check

Thanks for the reply. Atezr L2 has a USB-C interface, and I’ve never seen a USB-C cable with a ferrite core in my life. Anyway, I tried with a top-quality, short USB-C cable and the result is the same: it gets stuck at an arbitrary point halfway, with air assist on and the laser off. It’s not really a software freeze because if I hit “Stop” in LightBurn, Atezr will still respond and turn the air assist off.

Also, it never happens in the “Fill” mode, and I’ve engraved and cut a huge number of things using this laser over the last year. It only started to happen recently, maybe with a certain version of LightBurn.

UPDATE: interestingly, just found out that it seems to happen only when engraving right-to-left (job origin is center right), and not left-to-right. And it’s reproducible with other line-engraving, not only the one attached (but again only right-to-left).

Does that sound as a laser firmware issue?

Yes it’s the actual output. I don’t think there’s an issue there as I see it all the time (and I’ve engraved or cut hundreds of things with this laser without problem). Not sure what causes that.

is a bit abnormal to see weird characters on console, means part of the messages are being lost
what baud rate are you using? you can check on Edit → device settings
In fact if you can take a screenshot

It’s a fact that I’ve also never seen any USB Type-C cable with a ferrite core because I’ve never needed it, but I know they exist.
Noise in cables often impairs communication and more sensitive systems end up not working properly.
If using a top quality cable everything remained the same, the problem probably won’t have to do with noise in the communication.

I don’t see any baud rate here (does it even apply for USB?)

In the meantime, I received a new firmware from Atezr but I don’t seem to understand how I can flash it. Have been busy for days with their support trying to explain my problem and comprehend their replies…

Hi imager,

the problem there seems to be your Laser got Detected as Grbl LCP - where it should have been with Grbl only (Top of the list)

Click Devices button > Double click your profile > Change to GRBL

Click ok!

Also remind me your Atezr has Z axis?

Hm, no idea why it was detected as GRBL-LPC. I changed it to GRBL, but the problem persists.

Also remind me your Atezr has Z axis?

I believe it does, as it has a motorized Z axis and an autofocus function.

What also puzzles me is that I still see some out-of-order characters in the console, and also quite often LightBurn doesn’t detect the job is finished, so I have to manually click Stop. (That’s perhaps because it didn’t receive a proper ok message?)

Most certainly the message is being broken, but notice too you get
k
ook

So they come out of order as well.
Are you on the latest firmware?
For Sanity check, have you attempted connection via LaserGrbl?

You could save as Gcode a test project on Lightburn, and just run it via LaserGrbl.
What this test will do is validate if is a streaming issue or a software configuration issue.
If LaserGrbl also breaks then is something in hardware.
I suspect Firmware/EMF noise

The latter is not hard to test. Set a project at 1% laser power so is safe and does not produce any burning or smoke.
Then move the machine as far away from the current location as you can.
Same issues?
If so, then you are left with hardware problem variable.