Laser going negative after endstops installed

I have a diy laser with UNO/CNC shield running grbl 1.1h. Its been running fine but installed x- and y- endstops on the front left positions with a 2mm pull off. These were configured and working properly but the 0,0 point was in the upper right. I followed the setup guide and set $10=0 and I also set G10 L2 P1 x-660 y-660 which shifted the 0,0 to the front left. If I home it and check the coordinates they show 0,0. If I ask the machine to move G0 x100 y100 all works properly. I set up a job with the origin point in lower left and it drives - direction on both axis and crashes. I have disabled the endstops after fighting it for a few hours. Any ideas why it would go negative direction on a job but not while jogging?

A few background questions:

  1. Did you compile grbl yourself or is this a pre-compiled installation that came with the UNO/CNC?
  2. How are you homing if you have disabled the endstops?
  3. Where do you have the machine origin set in device settings?
  4. What are you using for Start From in Laser window?

Can you run these commands and post results here:

  1. $I
  2. $$
  3. $#
  4. ?

Can you attach a screenshot of your full LB window as well as a sample .lbrn file where you get this behavior?

Lightburn/grbl is not configured properly is a safe bet.

Since you changed ‘home’, did you change ‘home’ in Lightburn?

Where does your head show in Lightburn, relative to the object?

What ‘Start From’ are you using?

I understand the ‘Job Origin’ is bottom left…

Sometimes a screenshot helps…

:smiley_cat:

1 Like

sorry for the delay in responding. I built the laser engraver for my neighbour but he has been very busy engraving his cutting boards with the Christmas rush. I will get the screen shots over the next couple days as things settle down. We are using it without the endstops which I have just disabled in in grbl and lightburn. My unit has not been modified for the endstops yet and is in my unheated garage (-32c this morning). Before someone asks, we have both purchased separate licenses of Lightburn.

I’m sure when you get the ‘right’ bit set, it will function properly… sooo

When you added end stops, did you use the ‘home’ the machine has been using?

What I’m asking is if you changed it to where you would ‘like’ to have it home, as compared to where it ‘originally’ homed?

Since you don’t have end stops, where do you place the head when you power it up for a ‘home’ position?

Two things to check…

First is the ‘Start From’ and ‘Job Origin’ settings.

Screenshot from 2021-12-11 10-31-39

The second is how are you configured in the ‘Edit → Device Settings’ for ‘origin’

Screenshot from 2021-12-26 08-34-12

You answered the $I question, probably with the version of grbl you are running, “grbl 1.1h”. The $$ gives you your configuration, which can be read from ‘Edit → Machine Settings’, along with a text translation of what they do. Suggest you save a copy if you haven’t already. You may need to go back to a known starting place, so keep a ‘factory fresh’ configuration somewhere…

It takes 2 screenshots to get the whole thing on my machine, but it is much more clear to digest. I don’t have to find what $10 is used for via some other source to know it’s the ‘Status: Position reporting’.

My guess, is that you might need to be in ‘absolute coords’ mode in the ‘Start From’ box…

Here is what the Machine Settings screens should look like. This is my Xmas grbl, so have no idea about it’s values being legitimate.

For the $3 entry, you have to add up the bit pattern for the proper value

In the following, you will notice that $3 is referenced in 3 places accounting for all 3 axis directions.

I’m sure it’s just not configured properly, so hang in there…

:smiley_cat:

I am going to drag my machine into the house and set it up the same as my neighbors and test it here. That way I can take screen shots and try thing without disturbing his work. It will also help me learn the lightburn a bit more as I was working in lasergrbl and laserweb4 for my needle cutter/laser work. I am going to see if I can use the lightburn with the foamboard needle cutter as well. The needle cutter uses the pwm pin to drive a servo.

This is a neat idea. Is the servo variable speed? I assume for a needle cutter you’d always want the needle to be spinning at the same speed. You may be able to simulate this with “Constant Power” in cut settings. Or else you may need to turn off “Laser mode” in GRBL. $32=0.

The needle cutter uses a rc brushless motor and flywheel much like a sewing machine needle and the servo adjusts the height of cut and can vary it for full or partial cut. Check ERC Timsav on youtube.

I’ve seen these videos and kits. Pretty neat stuff.

I setup my machine with endstops and the same grbl settings as the neighbors machine and it worked fine so I will check his device settings in Lightburn. I may try setting up his machine from scratch again to make sure it was done properly. The only setting that I didn’t set on mine was $13=1 as he uses inches. I wasn’t able to test the needle cutter as It required a fork of GRBL 1.1h with servo control which changes the pwm frequency and I didn’t want to though a variable into the testing. I will load up a second uno with the servo version and test later.

Irrespective of whether or not he uses inches from a design perspective, this should be set to mm as that’s how the communication from LightBurn to the controller is expected to occur.

thanks I will test that on mine and see if that’s the problem

Also, if you have the endstops connected and homing, you should not have to set an offset and you should be able to use machine position ($10=1 or $10=3).

I had mine working fine but at one point I screwed up and it was going negative so did some checking and somehow my g54 settings were something like 17600. I zeroed them with the G10 L2 P1 X0 Y0 and then set them to -660 on both axis and it worked fine. Don’t have a clue how that got changed. As for the servo based needle cutter, I got it working by setting up a second device and used the M3 driver even though I am using 1.1h_servo for firmware on my board. When I used the M4 I would get the servo dropping but would not raise when travelling. So its just a matter of selecting which device and change the $32 setting for laser or needle cutter. Now to learn the finer points of the software!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.