Laser GRBL working fine, Lightburn isn't

Hope someone can help me, I have read all the threads and advice re getting Lightburn working but still no success for me. I’m running GRBL 1.1F on a 3018 Pro with laser and test images are burning fine on MDF material when I use program LaserGRBL, which is not my preferred program (I want Lightburn to work). In Lightburn, the same image that worked in Laser GRBL doesn’t work in Lightburn, exact same GRBL settings as below. So there must be another setting I’m missing within Lightburn. The laser fires and traces the image but it’s not burning. Settings are:
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

Any suggestions welcome, thank you.

Hi, I have a 3018 which is working fine. My $110 and $111 ( max speed) are set to 2250, albeit I’ve never gone above 2000 mm/m. Also it may be worth a try, changing your acceleration settings, $120, $121 to 200.

It may help.

Thanks, I’ll try it later today and let you know. I’m keen to purchase Lightburn but only if I figure this out.

Your machine is currently limited to 200 mm / minute. If you ask the controller to go any faster than that, it can’t, so it will decrease the output power instead, so that you get the exact amount of burn you asked for.

LaserGRBL uses the equivalent of LightBurn’s GRBL-M3 driver, which uses constant power output. That means it just fires the laser exactly at the power you asked for, whether it can attain the requested speed or not, but it also chars the heck out of start and end points.

So either:

  1. limit your job speed to 200 mm/min (which the machine is doing anyway, so it’s pointless to ask for faster).


  1. Use GRBL-M3 instead GRBL in LightBurn, which will give you the same output as LaserGRBL.

Working!! Thanks you guys are awesome!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.