Laser head hitting the frame & making loud noise

My laser homing is correct but once I try to start working in the midle it will move the laser head so far and start hitting the frame of cnc making loud noise

sounds like you have either the bed size set incorrectly, or the X and Y axis dimensions in machine settings. Assuming it’s only hitting the opposite sides to the limit switches. if it’s also hitting the side the limit switches are on then they are not working as intended

Could you please send me the correct setting

These are my settings

Have you made any configuration changes? Ortur lasers should work correctly out-of-the-box.

Was this working at one point? What’s the situation?

I enter some codes after watching a youtube video in cosole which is $22=0 then I enter the other one $22=1 and if it this issue hwo could I reverse these code

Is there a reason you were trying to change the homing direction? Normally there’d be no need to do this.

Can you run these commands in Console please:


I enter all the codes but I still have

the same problem

These are my machine settings

I wasn’t offering a fix, it was to get information to help troubleshoot the problem.

A few tips for going forward. If you need to get information from the computer screen, don’t take a photo, take a screenshot. If I ask for information that’s in the Console, copy the text into a reply, not a photo or a screenshot. Will make it much easier to get the details required.

I do not see anything majorly wrong with your settings from what I can see.

Minimally you should re-enable soft-limits. This will hopefully reduce the chance that you will crash into the walls. Enter this into Console:


What exactly are you doing when the laser is hitting the frame? Can you explain step-for-step the setup?

Also, what is your setting for “Start From” in Laser window? Can you take a screenshot there?

I deleted your duplicate post.
Your efforts in this thread appear to be moving in the right direction.

I had this experience where my X-axis was incorrectly wired on a Chinese CNC. I simply swapped the two wires sending signal to the X-axis stepper controller around, and works perfectly now. If it hasn’t worked correctly since day 1, I would consider this a possibility, otherwise, if it worked fine before, then it’s likely a software issue.

I can’t offer an answer cause I am still having a similar problem, but my limiter was dead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.