Laser head not homing and get position not reading 0

Hi guys. I have a Laserscript 6090 which i have upgraded from a leetro controller. I have upgraded to the Ruida RDC6432G. I used the wiring diagram from mw laser and got everything up and running and also got the settings sent to me for the laser by the company who i originally bought the laser from. All works well cutting wise but have to press origin every time I do a job (not sure if this is something that needs to be done all the time).

The issue I’m having though is the head wont home and stop to my set point which is the top right. If it homes it will go past the triggers (which are the blue sensors in the body and in the gantry) it hits the side and keeps trying to move until i press the emergency stop button. One thing ive noticed was when I press the get position when the head is at the top right 0 it says x900 or 9000+ and the same for y.

If i use the key pad to move the head to its limits it will auto stop where i have to press esc to start the machine again. This works in both directions so it knows where the edges/limit switches are.

If anyone could shed any light on this it would be awesome. Unfortunately I’m not near the machine to screenshot the vendor setting

Thanks in advance

This lengthy discussion around Ruida homing setup may sort things out:

You won’t have miswired switches, but getting the polarity correct requires the same attention.


Now, I have a new issue. When trying to calibrate the Z-Axis (which is 8.0 inches, (203MM) I can’t seem to get it to calibrate, I have tried all the settings I can think of. Cant get the Limit Switch working. It is setup as all others are. I have the switch at the top right front side. And the system is still reading 3000MM and it is only 203MM.

That’s the default value when homing hasn’t succeeded; the X and Y axes default to something like 10 000 mm.

Have you:

  • Enabled Z axis homing in the Edit → Machine Settings → Vendor Settings list
  • Sorted out the homing direction & keypad direction polarity / inversions
  • Verified that the switch operates correctly
  • … and appears active in the diagnostic panel when you manually trigger it

With that in mind, however, Ruida controllers apparently have a deeper configuration level inaccessible to LightBurn. My machine has an autofocus probe triggered by a key on the console, which is entirely independent of the config settings I mentioned. Bonus: it’s on the U axis, rather than the Z axis.

No matter what the settings, it doesn’t want to home the U axis at power-on. This is a Good Thing, because the autofocus probe generally wouldn’t contact anything with the head at a random position on the platform.

Because the controllers are intended for lasers, rather than CNC machines, it may not be possible to force the Z (or U) axis to home automatically during startup.

All the toggle switches are new to me as my leetro controller was set and run near enough instantly.

What will toggling the polarity achieve/do. I did have issues before I got the machine settings with the direction keypad but that’s all fine now.

Bet it’s something so simple.

I’ve been trying to use the print and cut feature to try and make stickers but it doesn’t want to play nicely ha ha

I wrote up what I knew about Ruida homing my blog:

And Z-axis focus settings:

Which is basically all I know on the subject … :grin:

Awesome. I’ll give that a read.

Should changing the settings on the controller panel be any different than changing the on Lightburn ?


Seem to have the Polarity, Homing, Keypad figured out. Have ensured the switch is good. And is still going to 3000. However it still is not homing on turn on, nor reset. When I use the control panel to do Z-AXES reset everything works fine, even homing. But when it is hard reset it goes back to not working again. I am At a loss for what to do next.

Also still unable to figure out the axes height issue. The actual height is 8.25inches, which is approx 215mm, using 8mm rod

Not homed = default axis position.

Without homing the Z axis, the controller does not know the location of the 0.00 coordinate, so it sets the position to the default 3000 (in your machine) to allow motion in either direction from wherever the platform might be. After homing, the machine will not travel below 0.0 at the home position to avoid collision with the frame.

So it doesn’t matter what length you set for the Z axis: without homing, that length is never used.

AFAICT, the configuration setting(s) allowing the Z axis to home automatically, if they exist, cannot be set by LightBurn or reached through the machine console. RDWorks might be able to expose that setting, but I haven’t had any reason to find out.

I think each axes can be enabled to home …

Or did I misunderstand your comment?


I have the Z AXIS home set to true. But still not homing through LB, however as stated above, when I do the AXIS reset function through the Rd Control panel all works until I turn the system off then back on.

Another issue is getting the right motor travel setup. Not haveing any luck on it due to the Homing issue, and not recognizing the stop switch, unless Control Panel reset…

In an earlier note I mentioned the absurd result: “No matter what the settings, it doesn’t want to home the U axis at power-on.”

Even with U axis homing enabled, it doesn’t home.

Which makes no sense on the face of it, so I assume the controller has a deeper setting tucked away inside, where we can’t see it, that enables auto-focusing and disables homing.

Even though, of course, both operations use the same hardware in the same way to get the same result.

Some of these controllers don’t use the optional axes as we would expect.

If the U axes is used to move materials under the laser, there is no home function that’s useful in that situation… such as after the job, it moves a conveyor belt to move the next object to be lased… I think we have something similar with a 6442, the U axes is not applicable for using it with a rotary, yet a rotary on the U axes works with a 6445.

These controllers are always surprising me, so something like this wouldn’t really rock my boat, if you follow.


So after I rang the company I got my machine from we were both scratching our heads at the 0.0 reading in the top right corner. We went through all the settings that they use on their machines and still nothing.

Five minutes after hanging up I got an email saying to try and reset the xy axis. I did this and the head flew straight to the bottom of the machine which was strange as mine homes to the top. I moved the head to the top and did a reset again. Low and behold it set it to 0.0 so now my machine finally knows where its home finally is ha ha

Now that works I’m happy. Downside is I’ve got to reset the machine every time I use it as I still can’t get it to home when the machine starts or if I press the reset button I’ll have to do an axis reset again.

If anyone knows why it’s still not homing that would be great. The machine still homes after it’s finished a job but not on startup