Laser head only moves 1/2 amount it should

If I go to X0 Y0 and type command G0 X100, the head only moves 50mm, not 100mm.
If I run a job, the head engraves the text at 1/2 size, not full size.
I have spent hours and hours reading documentation and trying various settings, but nothing works.
Machine is grbl1.1. Bed size is set in mm.

Does it work correctly if you use other software? If not, then you likely have GRBL configured incorrectly for $100 (X steps/mm) and $101 (Y steps/mm). It could also be that you have micro-stepping on your stepper drivers set up wrong using the shorting pins. A quick fix is to go to Machine Setting (under Edit menu), expand the Output setup section and change “X Steps per mm ($100)” and “Y Steps per mm ($101)” to twice their value. For example if currently set to 80, change to 160. Click Write and OK.

Do you have the Rotary Mode switch enabled? This is a pretty common one. If you don’t, then the machine steps for the Y axis likely need to be changed, as Bruce describes above.

About ready to give up.
I went in to the settings as you suggest and they were set at 800 so I changed to 1600.
When I now enter G0 X100 it goes way to far, probably around 180 mm.
If I then enter G0 X-100, it then goes back about 150 mm.
I also noticed set origin and go to origin totally do not work.
Thanks for trying to help.
Is there anyway to reset Lightburn back to original specs?

You need to get a ruler and measure the actual travel and adjust $100 until x-axis is correct. There is a button under Machine Setting for “Calibrate axis” that walks you through it. However, it doesn’t make sense that +X goes 180 but -X goes 150. Something else is wrong. Also, go to Tools…Rotary Setup to make sure Enable Rotary is switched off (red).

The machine is totally erratic. If I enter G0 X50, it goes to the right 100. If I then enter G0 X-50, it goes to the left 50, which is correct. If I then enter G0 X50, it goes to the right 50, which is also correct. If I then enter G0 X-100, it goes left 75, which is not correct.
Also, rotary is not switched on.
Also if I then enter G0 X-25, which should make it go left again, it goes right.
???
The above results were using Lightburn on my iMac.
Below are results using Lightburn on my Windows 10 laptop.
G0 X100 =+125 right
G0 X-100=-100 left which is correct
G0 X-25=+37.5 right
G0 X-50=-10 left

Yes, all very strange. I am at a loss. If you want to rule out LB, there are a lot of g-code senders you can use that will allow you to jog and test. Here is a simple one I use:
https://github.com/villamany/3dpBurner-sender/releases

OK, I tried the sender you suggested and results were erratic much the same as Lightburn.
I then tried LaserGrbl and it seemed to send the commands OK and machine moved in right direction and moved the same amount with + or - commands, but it only moved 1/2 of what it should. So if command was G0 X100, it only moved 50.
Guess I will try contacting Sainsmart and see if they have any solution. The cnc is Genmitsu 3018 Pro and the laser is 5.5w Laser from Sainsmart.
Thanks for all of your help.

1 Like

One other suggestion is to check $120/$121 acceleration. Should be 50 or less. But I would think these would be optimized by SainSmart. Here are their recommended values: https://docs.sainsmart.com/article/9m0rbnw6k1-introduction-to-cnc-for-a-total-novice-tuning-gbrl-settings

$120/$121 are set at 10.
I tried using Candle, which is what I have been using to run my CNC router with no problems. Using it as a router has always worked correctly.
When I opened candle with the laser mounted on the cnc machine and issued various G0 X? commands, I got the same erratic results.
I’m going to unhook the laser module from the circuit board and see if that changes anything. Will also contact Sainsmart support and see if they have any suggestions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.