Laser homing and location

Working on trying to fix my laser issue. I started this back in April and had to walk away from this for a bit.

I have a FoxAlien Masuter Pro, originally it had a base of 400X400 … I got the expansion base and took it to 400X800 And not my machine is all out of wack. When I home it, homes at a -397 / -797 ( below is the Mpos ) when I send it to 0/0 it goes to the middle of the board. Mpos reads then -377.0, -377.0 From here if I send it to 400/400 it goes to Mpos 8.350, -5.600 which on the actual board it’s physically at closer to 400/800 area homing from here it goes to one of the opposite corners from those two. What should be either 0/400 or 0/800 if it goes to what should be 0/800 it locks up and give a homing error and has to be shutdown and restarted.

I’ve posted the $$ settings. Can anyone offer any advice on this mess I’ve created? Currently this laser is a paperweight lol it’s aggravating at this point

Thanks!!

$$

$0=10

$1=255

$2=0

$3=0

$4=0

$5=0

$6=0

$10=3

$11=0.010

$12=0.002

$13=0

$20=0

$21=1

$22=1

$23=3

$24=25.000

$25=1000.000

$26=250

$27=3.000

$30=1000

$31=0

$32=1

$100=80.000

$101=80.000

$102=1600.000

$110=2000.000

$111=2000.000

$112=500.000

$120=300.000

$121=300.000

$122=30.000

$130=400.000

$131=800.000

$132=50.000

ok

?

<Idle|MPos:-397.000,-797.000,-3.000|Bf:35,253|FS:0,0|Ov:100,100,100>

<


I think you need to enter these commands into your console window to get your laser into 0, 0 when homed in the bottom left corner. You can add macros like in my photos so that you can switch back and forth between laser and cnc.

1 Like

Thanks for the reply Jess. Could you help me understand a little more what you think here.
I am not switching between laser and router, is that what you mean by cnc to laser? Although I’d like to eventually, so that’s helpful to know.
With change $10 from 3 to 0 , am I correct that would mean Enable WPos: Disable MPos: - not that I understand what that means lol could you break that down of what that would do?

This is where your machine ‘thinks’ it is.

You need to correct it, your home origin should be 0,0, not -397.000,-797.000.

I was under the impression you had a FoxAlien Masuter Pro with a laser module. That is what I mean by cnc to laser.

$10 is your status report.

1 Like

Yes, I think I follow you now, sorry for my confusion.

So I was test out a few positions before I saw your last message. I had it homed where it wants to go, the -397 spot… I sent it to X0 Y200 then to 0/0 … it’s not recognizing half the board cords, it 0/0 at what should be 0/400 … so correcting that sending back home and then by changing $10 to 0 from 3

Am I understanding the mission properly?

I so appreciate your help here!!

You are awesome !!!

Freaking works perfectly now!!

Thank you so much for the help !

2 Likes

Laser operates in the +X+Y quadrant. Lightburn requires this.

CNC operates on the -X-Y quadrant or all 4 quadrants where workspace center is 0,0 ; Depends on the programmer’s preferences.

If you are going to do both CNC and Laser on the same machine, +X+Y works for both modes. It also simplifies managing the controller parameters when switching.

2 Likes