Laser homing ruida controller

I have a omtech 50 watt laser I did a default reset per omtech support the laser will go to top left but wants to go to bottom right. How do I change it in the controller it thinks 0,0 is top left

In Machine Settings, check and see what Return Position it is set to. I’m not in front of my 50w at the moment but I believe I changed mine from Absolute Origin to Origin and now it stays in the upper left corner after homing. If I read your post correctly, I believe that’s what you’re trying to accomplish. If not, never mind.
Machine Settings - Return position

Did OMTech have you make a backup of the configuration? If you did a ‘factory’ reset, all the manufacturers configuration has been lost… which is what it sounds like.

OMTech should have given you something to re-load it with.

The display indicates a failure to home and your statement of how it’s booting or trying is unclear. Are you saying, on boot, it should go to the upper/left but it’s heading to the bottom/right?

If they/you don’t have a backup, try going into ‘File → Load prefs backup’… see if Lightburn can save you bottom…

Good luck


I made a back up file and screen shots when i frist got the laser, saved them on a thumb drive but cant find the thumb drive. I did a set to default para they told me not to do a factory para per omtech support. Tech has not sent me a file to write to the controller yet they wanted me to do the default para first. Also its the weekend no support till monday.

I will look when i get home tonight

The Ruida screen shows maximum values for X & Y axes, so the machine has failed to home.


My is set to origin I just set it to absolut origin now on the controller it shows x and y are zero thanks for the help

Will like i said it homes stays in upper left but when i do to pulse the laser now it is saying its protected so im assuming its the water protector relay i see it checked in the laser machine setting also i thought i check to see if i still get out of bounds it still get it. bionicback do you have the OMTech 50 watt could you please take a sceen shot of your setting and or download your machine files and send them to me.

I got it to fire now just still showing out of bounds.

The ‘user’ origin can be set on the Ruida, actually I think it has four for production reasons…

The Ruida has to home, otherwise it has no idea where it is. The machine always maintains it’s machine origin and the ‘user’ origin.

When you use Lightburn and select ‘start from’, in the laser window, that lets Lightburn send the right codes to tell the controller to use ‘user origin’, ‘current position’ or ‘absolute coordinates’ (machine origin).

I hope that makes sense…

It should ‘say’ if it was a door protect or water protect problem. You can physically look at the controller and see some of these signals displayed on it’s led system. They ‘illuminate’ when they are active (pulled low, generally).

You can also see if the machine is actually seeing them on the machines console. Z/U → Diagnostics will show you what it’s reading as the state of these inputs.

There is also the limit switches displayed here.

Here are mine… this is the oldest one I have so check things or compare your file with mine.

If you load it and attempt to run it … it’s your problem if there are issues… You should have a backup of the current configuration anyway…


On the Ruida?

Keep in mind that when you post a problem, then the next post is “It’s working”, it makes it difficult for us to follow what’s going on. The other angle here is that as a person with a laser problem, has that exact same issue, they’ve gotten nowhere reading the post.

If you get an error message, let us know from whence it came. Just take a couple minutes and realize we haven’t ‘just talked to you’ and probably are not totally in sync…

Good luck


Jack’s last post should have you all squared away. If you still want a copy of my settings, just let me know.

Its working it was that one setting once i change it like i said it homes and stay at the top left i did back up files and took screen shots and have them saved to a thumb drive thanks for the help

Its was a loose wire for the door protection that was the error i was getting. Its fixed now.

1 Like

It should have said door protection or something similar…

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.