Laser in System shows busy all the time and will not respond

The word Alarm is interesting.

Please do this again and when the result repeats, unplug the usb cable, scroll back in the Console window and Select, Copy and Paste the first 20 lines or so if that’s where the Alarm or Error message seems to have started.

It appears that the GRBL Interrupt Mask isn’t active.

After you reconnect the cable, the engraver will likely resume the communication where it left off. (If it doesn’t connect, Right click the Devices button in the Laser window. This sends a hard reset to the controller.) After you reconnect, please request the Machine settings by entering the following into the Console window:
then press enter.

Unplug the USB cable again so the messages stop scrolling.
Then select the whole report (with your cursor) in the Console window and copy and paste it into a reply here.

I’m looking for a continuous reporting option being enabled. It shouldn’t be causing the error.

The setting for $10=1 is most common for most laser engravers.
The Foxalien community has a few posts suggesting that $10=0

This may be of interest:

2 posts were merged into an existing topic: LightBurn Connects to GRBL Firmware but not other Genmitsu Firmware

Thanks John:
I tested the laser module and found it to be bad per the Fox Alien guidelines. Thanks for the response. If you know how to get fast service from the Fox group please share

This sounds like a very different problem than what was described in the first part of your post.

I don’t have any influence to accelerate hardware warranty issues with manufacturers.

If you’re interested in sharing, I am interested in the Fox Alien guidelines for Laser module testing. It may help us help others.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.