Laser is homed but not at zero

When I home my laser it shows x 0, but Y is at 7.874. why is the Y not at zero too?



You likely have a homing pull-off set or an offset configured.

Is this for the C3D converted K40 in your profile?

I’m not super familiar with the conversion process but was there a calibration process you needed to follow?

Yes, it is a converted K40 with a C3d board. I never had to calibrate anything. I have been using it for a while and was watching some youtube video on light burn and noticed mine was not at 0,0.

Does X value get higher as you move to the right? And similar for Y value as you go up?

Is the controller running in GRBL mode? Can you see if these commands return values in Console? If so, please copy/paste output of these commands in a reply:


Also just noticed something. You’re saying the the 0,7.874 is immediately after homing?

Where does your laser home to?

Please send screenshot of Edit->Device Settings.

It homes to the upper left, but is in reverse in light burn.


[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F24000.0000 S0.0000]



error:Invalid statement























Can you explain what this means? What exactly is reversed?

Did you run the ? command from the home location?

Can you confirm your bed dimensions? Is it meant to be 300x200 mm (standard K40)? You may want to switch your units in LB to mm at least while you’re doing your configuration.

Yes, this was the output from the ? at the home position.





Not sure if you were done responding but can you answer these other questions as well please?

This issue is almost certainly related to your Y axis definition in LB not matching the configuration in your controller but need details to confirm.

my K40 has it’s home switches in the upper right corner. But if I put the position in LB, then it flips it 180 degrees. in LB setting if I put the bottom left corner as home, then whatever is in LB show normally. Yes, i switched over to mm and my bed is 300 x 200

Okay. Machine origin in Device Settings is not equivalent to homing position. They’re unrelated concepts.

Try this change:

  1. First make sure the units indicator on the Numeric Edits Toolbar reads “mm”. Switch from “In” if required by clicking on the units.
  2. Under Device Settings change your Working Size “height” to 200mm. I believe your current setting is the equivalent of roughly 250. If your “width” settings is not exactly 300mm go ahead and change that too.

Rehome and then check 4 corners for position and report back.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.