Laser keeps changing position slightly


I am completely new to the world of laser engraving. I bought a cheap laser from Vevor VEVOR Cnc3040,cnc Machine 5500mw, Cnc Router Machine Laser Engraver For Wood Plastic | VEVOR UK

I’m not trying to achieve much. I bought some bamboo desktop phone charger stands I want to engrave with my business logo as gifts. Its cheaper to give this a go rather than pay a £20-£30 engraving charge on a £13 item to buy a laser and DIY when you have 45 of them to do.

Anyway, I have spent the last couple of days experimenting. I have a couple of problems.

The first is the image prints out mirrored. I’ve built the laser to the instructions and double checked everything, even set the origin to front left. I’ve go around that by just flipping the image on Lightburn after I have made it. I’m passed that for now, its an annoyance that I will come back to.

However, the most annoying one is this and the one I really need suggestions with

When I frame it , the laser will draw out the area fine. If i run it again, the area moves slightly forward and so on and so on as its walking the area back to the front by about 2mm a cycle.

The issue is that if i need to engrave with more than one pass then i get a distorted image because the second burn is off by about 1-2mm from the first.

I can’t figure out why. I’ve tightened the belts and made sure the laser is on a solid level bench

Any ideas?

If you run 2 passes on a cut without stopping do you get the same issue? Or is this only if you complete a job, then try to rerun?

If the latter, then it’s possible that somehow you’ve some mechanical stress that’s pulling the laser head out of it’s resting position after the steppers have powered down. Look for something that might be causing a spring action. Since this is on the Y-axis make sure that the gantry is square to both sides of the Y. If you pull the gantry all the way forward and all the way back, do the left and right sides engage the front and back at the same time? Or does one side touch first? If the latter, try to sort out what’s causing that and address.

If nothing can be found you can experiment with changing $1 GRBL configuration for Step idle delay. This is the time in ms the steppers are kept engaged/locked before the stepper is disabled when idle. Setting to 255 keeps them always on. It would be preferable to sort out any mechanical issue before resorting to this.

How do you have the laser oriented? Is controller to the front or back?

Does your machine have limit switches and go through a homing cycle? If so, to what corner does it home and what are the coordinates after homing (use get position in Move window)?

If it doesn’t home, start the machine with the laser head at front left. Record coordinates. Jog laser head to each corner and record coordinates. Report back please.


Thank you for your reply. I will review the suggestions you’ve made when I return from work (Thursday). Maybe one of the tracks are tighter than the other, though I’ve not heard any slipping. Or maybe they are too tight. I’ll experiment. Thanks for the suggestion on keeping the steppers active

For the laser orientation i have it like this picture, except the controller board is mounted on the outside of the crossmember rather than on top in this picture and the motor and track is on the underside of the X frame not at the top in this picture (though not sure this matters as the instructions where to do this which contradicts the picture).

This a change that you introduced or you’re saying that the instructions included this information? I’m wondering if it’s possible that the change in location has resulted in an inversion of the effective direction of the motor but the controller is configured with the original orientation. If so, this could result in direction inversion.

When you get back, can you run one additional test in addition to the coordinate test?
Start from home or machine at front-left. Can you confirm if jog controls work as expected or if they are inverted. Check all 4 directions.

Also run these commands in Console after homing:


I got back and checked. The laser drifting was indeed mechanical the Y axis tracks weren’t fastened down tight enough and not being on an exact level meant it moved under gravity a little.

For the laser going back to front I’ve worked it out. Front left setting is actually rear left so I’ll need to rotate the X arm 180 degrees.

But now I have consistently in multiple passes. Thank you for your help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.