Laser keeps firing during moves

I’m having a problem with my laser cutting during moves. It happens randomly and I can’t replicate it. Most of the times, a file will cut perfectly fine, and then occasionally, the laser will fire during moves. Happens with all kinds of files, all Smoothieboard firmware versions of the last year or two and all Lightburn versions of the last year or two.
Any help or pointers would be appreciated very much!

If you run the same file twice, it may or may not do it? Does it do it in the same spot when it does?

If you run the same file twice, it may or may not do it?

Sometimes it does, most of the times it will run fine again (until eventually it happens again).

Does it do it in the same spot when it does?

Can’t say for sure, I would think yes, it does. Will pay attention the next time it happens.

Here is a picture of the same job, run twice, without power cycling the laser or restarting Lightburn or changing anything else (beside the plywood). First run had cutting on moves, second was fine (third too, not pictured).

Does somebody know what this could be? Thank you!

That’s very weird. Unfortunately I don’t have any idea. My best guess may be a power supply issue? Maybe a wire that gets shorted out in certain locations? Sorry. :frowning:

I appreciate your thoughts on this.
I’ve found another similar issue posted here where the PSU was the culprit, so I’ll keep that in mind. Until then the manufacturer suggested moving the firing pin on the Smoothieboard, I’ll try that first.

Well keep us updated, in case anyone else has the same issues.

Will do. I know how frustrating it is to find dead problem posts without the solution posted. Or worse, something along “Nevermind, I solved it!”. :crazy_face:

1 Like

Yesterday I changed the fire pin on the Smoothieboard from 0.26 pin to 0.25 pin. Then changed this part in the config to

switch.laserfire.output_pin 0.25!v

Laser did a few jobs since then without errors, but since the problem only occurred occasionally, I wouldn’t call it solved yet. Will update what happens.

If the pin is active high instead of active low, you might want pull-up instead of pull-down (use a ^ instead of v after the pin number). I can’t say for sure that’s the issue, but since you have the pin invert flag (!) that’s a possibility.

Many thanks, Oz.
While my laser was operating normally again at first, it someday started aborting operations just in the moment when the laser would start firing. I.e. the laser head would move to the starting point and then just halted.
I remembered your comment and changed the config accordingly to:
switch.laserfire.output_pin 0.25!^

I’ve cut for several hours since then without any problems. Keeping fingers crossed here.

Quick update to say that the laser has been cutting for 20+ hours since my last comment and no problems so far. I’m a happy camper. Thank you, Oz!