Laser left burning after Pause/Stop/Frame

I have a K40 which I have replaced the controller with Arduino. I’m running GRBLS 0.9 and using Lightburn 0.9.16.
My first and main concern is that after a Stop, Pause, or Frame command, the laser is left on. Otherwise I’m getting good results. When a job completes, the laser turns off as expected. The laser is not left on when pathing.

Any clue what I’m missing?


I believe that is standard GRBL 0.9 behavior. Happens to me as well if I pause during a burn on my diode laser. I understand GRBL 1.1f with laser mode enabled prevents this since it shuts off the laser if it stops for any reason (uses the M4 GRBL command instead of M3). I’m not sure LB knows you have hit pause so nothing it can really do about it. Remember GRBL was made for CNC machines initially.

Cool, thanks. I will look into upgrading to 1.1f.

Hey, sorry to bug you. I upgraded from GRBL 0.9 to 1.1h last night. I setup all the GRBL settings ($0-$122) like the old implmentation. I also set $32 to 1 in order to enable laser mode. LightBurn moves the head, but can’t seem to fire the laser now. I remembered having to change the “INVERT_SPINDLE_ENABLE_PIN” in the config.h for GRBLs, so I went back, made that change and reloaded GRBLs. Still no luck. Any idea what I’m missing that prevents lightBurn/the arduino from firing the laser?

I’m not sure. Here are some thoughts: Did you delete your old LB device and set up a new one. It should use the GRBL profile and not the GRBL -M3 profile. Can you get it to fire in the console using M3? You can see what gcode LB is producing and compare it to gcode before you upgraded for clues perhaps. On my CNC shield I also have to use z-axis limit switch for laser PWM, but I think that was also needed in 0.9. Also note that M4 will not fire the laser if the laser isn’t moving so you can’t test it with that command in the console. Also note that I think max s value changed from 255 to 1000. This is a setting LB, but it usually figures it out for itself when you set up a new device. If you are still sending S255, the laser will only power on at 25% since GRBL is now expecting full power to be S1000.

I did find the setting and change the LB device from using GRBL-M3 profile to GRBL. But after you posted I deleted the device and recreated it. Still no joy.
If just typing m3 into the console is what you mean, then no, it does not fire the laser.
An interesting if somewhat terrifying discover is that now if I unplug the arduino from the usb port, the laser fires constantly.

Sorry it’s not working. I’m not familiar with K40 lasers and how they fire. What control board do you have? May have to contact them and ask if it supports 1.1.

Okay, I have made some progress. I am pretty sure the issue is somwehre in the Gcode or GRBLS.

I drew a couple of simple shapes and saved out the Gcode. I see the M8 and M4 commands right at the start. Then at the end there is a M5 and M9 command. The laser is firing at the start, drawing the shapes, then stopping firing at the end.
It doesn’t seem to respect M4’s “don’t fire when stationary”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.